768071387e
Reviewed by maya@ Changes: * marshal NULL strings as nil instead of empty strings. This allows use of e.g. DataInputStream:read_line() APIs. * fix and improve build for OSX and Win-based configurations * add support for arrays with lengths as struct fields * allow GLib.Variant construction for lightuserdata * fix gtop binding (certain structs could not be imported) * adapt to new set of annotations in newer glib * assorted Lua5.3 fixes, lgi is now fully Lua5.3 compatible * fix binding of Gdk.Rectangle from newer GDK
26 lines
1.2 KiB
Text
26 lines
1.2 KiB
Text
$NetBSD: patch-lgi_Makefile,v 1.2 2017/08/12 15:46:56 triaxx Exp $
|
|
|
|
Don't use mkdir and cp directly, use BSD_INSTALL_* abstraction instead
|
|
|
|
--- lgi/Makefile.orig 2016-05-27 19:56:36.000000000 +0000
|
|
+++ lgi/Makefile
|
|
@@ -80,11 +80,11 @@ OVERRIDES = $(wildcard override/*.lua)
|
|
CORESOURCES = $(wildcard *.lua)
|
|
|
|
install : $(CORE) $(VERSION_FILE)
|
|
- mkdir -p $(DESTDIR)$(LUA_LIBDIR)/lgi
|
|
- cp $(CORE) $(DESTDIR)$(LUA_LIBDIR)/lgi
|
|
- mkdir -p $(DESTDIR)$(LUA_SHAREDIR)
|
|
- cp ../lgi.lua $(DESTDIR)$(LUA_SHAREDIR)
|
|
- mkdir -p $(DESTDIR)$(LUA_SHAREDIR)/lgi
|
|
- cp $(CORESOURCES) $(DESTDIR)$(LUA_SHAREDIR)/lgi
|
|
- mkdir -p $(DESTDIR)$(LUA_SHAREDIR)/lgi/override
|
|
- cp $(OVERRIDES) $(DESTDIR)$(LUA_SHAREDIR)/lgi/override
|
|
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(LUA_LIBDIR)/lgi
|
|
+ $(BSD_INSTALL_LIB) $(CORE) $(DESTDIR)$(LUA_LIBDIR)/lgi
|
|
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(LUA_SHAREDIR)
|
|
+ $(BSD_INSTALL_DATA) ../lgi.lua $(DESTDIR)$(LUA_SHAREDIR)
|
|
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(LUA_SHAREDIR)/lgi
|
|
+ $(BSD_INSTALL_DATA) $(CORESOURCES) $(DESTDIR)$(LUA_SHAREDIR)/lgi
|
|
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(LUA_SHAREDIR)/lgi/override
|
|
+ $(BSD_INSTALL_DATA) $(OVERRIDES) $(DESTDIR)$(LUA_SHAREDIR)/lgi/override
|