8a49ae3870
* Fix catalog cache invalidation after a "VACUUM FULL" or "CLUSTER" on a system catalog * Fix incorrect order of operations during sinval reset processing, and ensure that TOAST OIDs are preserved in system catalogs * Fix bugs in indexing of in-doubt HOT-updated tuples * Fix multiple bugs in GiST index page split processing * Fix possible buffer overrun in tsvector_concat() * Fix crash in xml_recv when processing a "standalone" parameter * Make pg_options_to_table return NULL for an option with no value * Avoid possibly accessing off the end of memory in "ANALYZE" and in SJIS-2004 encoding conversion * Protect pg_stat_reset_shared() against NULL input * Fix possible failure when a recovery conflict deadlock is detected within a sub-transaction * Avoid spurious conflicts while recycling btree index pages during hot standby * Shut down WAL receiver if it's still running at end of recovery * Fix race condition in relcache init file invalidation * Fix memory leak at end of a GiST index scan * Fix memory leak when encoding conversion has to be done on incoming command strings and "LISTEN" is active * Fix incorrect memory accounting (leading to possible memory bloat) in tuplestores supporting holdable cursors and plpgsql's RETURN NEXT command * Fix trigger WHEN conditions when both BEFORE and AFTER triggers exist * more...
21 lines
839 B
Text
21 lines
839 B
Text
$NetBSD: patch-ad,v 1.2 2011/09/27 11:04:42 adam Exp $
|
|
|
|
--- src/pl/plperl/GNUmakefile.orig 2011-09-22 22:00:48.000000000 +0000
|
|
+++ src/pl/plperl/GNUmakefile
|
|
@@ -54,7 +54,6 @@ PSQLDIR = $(bindir)
|
|
|
|
include $(top_srcdir)/src/Makefile.shlib
|
|
|
|
-plperl.o: perlchunks.h plperl_opmask.h
|
|
|
|
plperl_opmask.h: plperl_opmask.pl
|
|
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi
|
|
@@ -64,7 +63,7 @@ perlchunks.h: $(PERLCHUNKS)
|
|
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi
|
|
$(PERL) $(srcdir)/text2macro.pl --strip='^(\#.*|\s*)$$' $^ > $@
|
|
|
|
-all: all-lib
|
|
+all: perlchunks.h plperl_opmask.h all-lib
|
|
|
|
SPI.c: SPI.xs
|
|
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi
|