65cb82f1cd
Highlights: - configure system rewritten and simplified - better emulation of SWI, especially of C-interface, allows: o port of SWI packages: sgml and plunit work better, clib, RDF, zlib and http seem to be working well, semweb compiles o better integration with C: it is now possible to call YAP from JPL reliably (all tests in the demos/java directory succeed in Linux) o it is now possible to create a stream with SWI routines and use YAP IO (parser, writer) on it o pyswip: YAP now includes a version of the pyswip package for experimentation: all the demos seem to be work (YAP must be compiled as a dynamic library) - compilation in Sun and NetBSD - YAP can now handle very, very large terms in compiled clauses. - several new builtins - improve thread implementation, especially locking in IO routines and indexing o fix C thread interface - fix odbc support in MYDDAS - fix overflow in == - fix bad call to subsumes/2 - new version of trie library, developed by Theo and Ricardo
15 lines
567 B
Text
15 lines
567 B
Text
$NetBSD: patch-aj,v 1.1 2010/08/10 07:49:57 asau Exp $
|
|
|
|
Fix staged installation.
|
|
|
|
--- packages/http/Makefile.in.orig 2010-08-04 21:36:28.000000000 +0400
|
|
+++ packages/http/Makefile.in 2010-08-10 11:26:28.000000000 +0400
|
|
@@ -110,7 +110,7 @@
|
|
$(INSTALL_PROGRAM) $(SOLIBS) $(BINTARGET)
|
|
mkdir -p $(PLTARGET)
|
|
mkdir -p $(PLTARGET)/web/icons
|
|
- mkdir -p $(LIBDIR)/web/css
|
|
+ mkdir -p $(DESTDIR)$(LIBDIR)/web/css
|
|
$(INSTALL_DATA) $(LIBPL) $(PLTARGET)
|
|
$(INSTALL_DATA) $(srcdir)/README $(PLTARGET)
|
|
$(INSTALL_DATA) $(srcdir)/web/icons/*.png $(PLTARGET)/web/icons
|