4acb4b6a7e
common makery into Makefile.common, add CONFLICTS for each package referring to the others, as for now the manpages will conflict. TODO: Use ALTERNATIVES system? How to handle manpages? Many bug fixes and some feature/documentation enhancements. The web site goes into this in much detail; also, see CHANGES.txt and RELEASE.txt in the source distribution. Also, see the change to patch-aa which ensures we use ${PKGVERSION_NOREV} to generate the version for the installation where appropriate.
22 lines
696 B
Text
22 lines
696 B
Text
$NetBSD: patch-aa,v 1.1 2008/11/15 01:16:49 bjs Exp $
|
|
|
|
--- setup.py.orig 2008-11-04 11:12:26.000000000 -0500
|
|
+++ setup.py
|
|
@@ -29,7 +29,7 @@ import stat
|
|
import string
|
|
import sys
|
|
|
|
-Version = "1.1.0"
|
|
+Version = os.getenv("PKGVERSION_NOREV")
|
|
|
|
man_pages = [
|
|
'scons.1',
|
|
@@ -353,7 +353,7 @@ class install_data(_install_data):
|
|
if is_win32:
|
|
dir = 'Doc'
|
|
else:
|
|
- dir = os.path.join('man', 'man1')
|
|
+ dir = os.path.join(os.getenv("PKGMANDIR"), 'man1')
|
|
self.data_files = [(dir, man_pages)]
|
|
man_dir = os.path.join(self.install_dir, dir)
|
|
msg = "Installed SCons man pages into %s" % man_dir
|