This commit fixes the run-libmicro command which was broken for all platforms. It was pointing at the destdir version instead of the installed version. It also provides a DragonFly-specific makefile which enables it to build and run on DragonFly.
50 lines
1.3 KiB
Text
50 lines
1.3 KiB
Text
$NetBSD: patch-al,v 1.1 2011/11/06 00:03:27 marino Exp $
|
|
|
|
--- /dev/null 2011-11-05 23:36:35.729938736 +0000
|
|
+++ Makefile.DragonFly
|
|
@@ -0,0 +1,45 @@
|
|
+#
|
|
+# CDDL HEADER START
|
|
+#
|
|
+# The contents of this file are subject to the terms
|
|
+# of the Common Development and Distribution License
|
|
+# (the "License"). You may not use this file except
|
|
+# in compliance with the License.
|
|
+#
|
|
+# You can obtain a copy of the license at
|
|
+# src/OPENSOLARIS.LICENSE
|
|
+# or http://www.opensolaris.org/os/licensing.
|
|
+# See the License for the specific language governing
|
|
+# permissions and limitations under the License.
|
|
+#
|
|
+# When distributing Covered Code, include this CDDL
|
|
+# HEADER in each file and include the License file at
|
|
+# usr/src/OPENSOLARIS.LICENSE. If applicable,
|
|
+# add the following below this CDDL HEADER, with the
|
|
+# fields enclosed by brackets "[]" replaced with your
|
|
+# own identifying information: Portions Copyright [yyyy]
|
|
+# [name of copyright owner]
|
|
+#
|
|
+# CDDL HEADER END
|
|
+#
|
|
+
|
|
+#
|
|
+# Copyright 2005 Sun Microsystems, Inc. All rights reserved.
|
|
+# Use is subject to license terms.
|
|
+#
|
|
+
|
|
+
|
|
+CC= gcc
|
|
+
|
|
+CFLAGS= -O -DUSE_SEMOP
|
|
+CPPFLAGS= -DUSE_SEMOP -D_REENTRANT
|
|
+MATHLIB= -lm
|
|
+THIS_ARCH:= $(shell /usr/bin/uname -m)
|
|
+
|
|
+ELIDED_BENCHMARKS= atomic cachetocache
|
|
+
|
|
+ifeq ($(THIS_ARCH),x86_64)
|
|
+ELIDED_BENCHMARKS+= getcontext setcontext
|
|
+endif
|
|
+
|
|
+include ../Makefile.com
|