6ee3203c43
Including fix for long title & history file problem. http://www.mozilla.org/security/history-title.html https://bugzilla.mozilla.org/show_bug.cgi?id=319004 What's New in Firefox 1.5 Firefox 1.5 is the next version of our award-winning Web browser. Here's what's new in Firefox 1.5: * Automated update to streamline product upgrades. Notification of an update is more prominent, and updates to Firefox may now be half a megabyte or smaller. Updating extensions has also improved. * Faster browser navigation with improvements to back and forward button performance. * Drag and drop reordering for browser tabs. * Improvements to popup blocking. * Clear Private Data feature provides an easy way to quickly remove personal data through a menu item or keyboard shortcut. * Answers.com is added to the search engine list. * Improvements to product usability including descriptive error pages, redesigned options menu, RSS discovery, and "Safe Mode" experience. * Better accessibility including support for DHTML accessibility and assistive technologies such as the Window-Eyes 5.5 beta screen reader for Microsoft Windows. Screen readers read aloud all available information in applications and documents or show the information on a Braille display, enabling blind and visually impaired users to use equivalent software functionality as their sighted peers. * Report a broken Web site wizard to report Web sites that are not working in Firefox. * Better support for Mac OS X (10.2 and greater) including profile migration from Safari and Mac Internet Explorer. * New support for Web Standards including SVG, CSS 2 and CSS 3, and JavaScript 1.6. * Many security enhancements. The Burning Edge has more detailed lists of new features and notable bug fixes. http://www.squarefree.com/burningedge/releases/1.5-comprehensive.html
88 lines
2.7 KiB
Text
88 lines
2.7 KiB
Text
$NetBSD: patch-do,v 1.2 2005/12/10 13:47:22 taya Exp $
|
|
|
|
diff -ruN ../Orig/mozilla/directory/c-sdk/config/DragonFly.mk ./directory/c-sdk/config/DragonFly.mk
|
|
--- ../Orig/mozilla/directory/c-sdk/config/DragonFly.mk 1970-01-01 09:00:00.000000000 +0900
|
|
+++ ./directory/c-sdk/config/DragonFly.mk 2005-12-04 19:44:55.000000000 +0900
|
|
@@ -0,0 +1,82 @@
|
|
+#
|
|
+# The contents of this file are subject to the Mozilla Public
|
|
+# License Version 1.1 (the "License"); you may not use this file
|
|
+# except in compliance with the License. You may obtain a copy of
|
|
+# the License at http://www.mozilla.org/MPL/
|
|
+#
|
|
+# Software distributed under the License is distributed on an "AS
|
|
+# IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
|
|
+# implied. See the License for the specific language governing
|
|
+# rights and limitations under the License.
|
|
+#
|
|
+# The Original Code is the Netscape Portable Runtime (NSPR).
|
|
+#
|
|
+# The Initial Developer of the Original Code is Netscape
|
|
+# Communications Corporation. Portions created by Netscape are
|
|
+# Copyright (C) 1998-2000 Netscape Communications Corporation. All
|
|
+# Rights Reserved.
|
|
+#
|
|
+# Contributor(s):
|
|
+#
|
|
+# Alternatively, the contents of this file may be used under the
|
|
+# terms of the GNU General Public License Version 2 or later (the
|
|
+# "GPL"), in which case the provisions of the GPL are applicable
|
|
+# instead of those above. If you wish to allow use of your
|
|
+# version of this file only under the terms of the GPL and not to
|
|
+# allow others to use your version of this file under the MPL,
|
|
+# indicate your decision by deleting the provisions above and
|
|
+# replace them with the notice and other provisions required by
|
|
+# the GPL. If you do not delete the provisions above, a recipient
|
|
+# may use your version of this file under either the MPL or the
|
|
+# GPL.
|
|
+#
|
|
+
|
|
+#
|
|
+# Config stuff for DragonFly
|
|
+#
|
|
+
|
|
+include $(MOD_DEPTH)/config/UNIX.mk
|
|
+
|
|
+CC = gcc
|
|
+CCC = g++
|
|
+RANLIB = ranlib
|
|
+
|
|
+OS_REL_CFLAGS = -Di386
|
|
+CPU_ARCH = x86
|
|
+CPU_ARCH_TAG = _$(CPU_ARCH)
|
|
+
|
|
+OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) -ansi -Wall -pipe $(THREAD_FLAG) -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
|
|
+
|
|
+#
|
|
+# The default implementation strategy for FreeBSD is pthreads.
|
|
+#
|
|
+ifeq ($(CLASSIC_NSPR),1)
|
|
+IMPL_STRATEGY = _EMU
|
|
+DEFINES += -D_PR_LOCAL_THREADS_ONLY
|
|
+else
|
|
+USE_PTHREADS = 1
|
|
+IMPL_STRATEGY = _PTH
|
|
+DEFINES += -D_THREAD_SAFE
|
|
+THREAD_FLAG += -pthread
|
|
+endif
|
|
+
|
|
+ARCH = freebsd
|
|
+
|
|
+MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
|
|
+
|
|
+ifeq ($(MOZ_OBJFORMAT),elf)
|
|
+DLL_SUFFIX = so
|
|
+else
|
|
+DLL_SUFFIX = so.1.0
|
|
+endif
|
|
+
|
|
+DSO_CFLAGS = -fPIC
|
|
+DSO_LDOPTS = -Bshareable
|
|
+
|
|
+ifdef LIBRUNPATH
|
|
+DSO_LDOPTS += -Wl,-R$(LIBRUNPATH)
|
|
+endif
|
|
+
|
|
+MKSHLIB = $(LD) $(DSO_LDOPTS)
|
|
+
|
|
+G++INCLUDES = -I/usr/include/g++
|