f9a2c69fe5
Murray Armfield <murray@river-styx.org>, thanks! Changes include: - several new CGIs - WAP interface - forced service checks - acks w/o notifications - custom intervals for notification escalations - passive check submissions via web interface - auto-save of retention data - extended service information - scheduled downtime - service dependencies - flap detection - aggregated status updates - new macros - user-supplied coordinates in status map - minor bug fixes and tuning
33 lines
962 B
Text
33 lines
962 B
Text
$NetBSD: patch-ab,v 1.2 2002/03/25 12:54:19 rh Exp $
|
|
|
|
--- cgi/Makefile.in.orig Mon Dec 24 08:23:45 2001
|
|
+++ cgi/Makefile.in
|
|
@@ -14,7 +14,7 @@
|
|
LOGDIR=@localstatedir@
|
|
CFGDIR=@sysconfdir@
|
|
BINDIR=@bindir@
|
|
-CGIDIR=@sbindir@
|
|
+CGIDIR=@libexecdir@/cgi-bin
|
|
HTMLDIR=@datadir@
|
|
INSTALL=@INSTALL@
|
|
INSTALL_OPTS=@INSTALL_OPTS@
|
|
@@ -24,7 +24,7 @@
|
|
|
|
CP=@CP@
|
|
CC=@CC@
|
|
-CFLAGS=@CFLAGS@ @DEFS@ -DNSCGI
|
|
+CFLAGS=@CFLAGS@ @DEFS@ -I${PREFIX}/include -DNSCGI
|
|
#CFLAGS=-O3 -Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -DHAVE_CONFIG_H -DNSCGI
|
|
LDFLAGS=@LDFLAGS@ @LIBS@
|
|
|
|
@@ -142,8 +142,6 @@
|
|
devclean: clean
|
|
|
|
install:
|
|
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CGIDIR)
|
|
+ [ -d ${DESTDIR}${CGIDIR} ] || ${BSD_INSTALL_DATA_DIR} ${DESTDIR}${CGIDIR}
|
|
for file in *.cgi; \
|
|
- do $(INSTALL) -m 775 $(INSTALL_OPTS) $$file $(DESTDIR)$(CGIDIR); done
|
|
-
|
|
-
|
|
+ do ${BSD_INSTALL_SCRIPT} $$file $(DESTDIR)$(CGIDIR); done
|