7c34813f59
this build with NetBSD make older than Dec 26 2003. Problem was that ${FOO:$o=.lo} was not expanded as in GNU make before that date; problem found by Thomas Dickey. Remove USE_GNU_TOOLS+=make.
22 lines
832 B
Text
22 lines
832 B
Text
$NetBSD: patch-ad,v 1.8 2004/03/08 13:26:03 wiz Exp $
|
|
|
|
--- c++/Makefile.in.orig Fri Jan 16 23:44:56 2004
|
|
+++ c++/Makefile.in
|
|
@@ -149,7 +149,7 @@ LIB_OBJS = \
|
|
|
|
../lib/$(LIBNAME_LIBTOOL) : $(LIB_OBJS)
|
|
cd ../lib && $(LIBTOOL_LINK) $(CXX) $(CXXFLAGS) \
|
|
- -o $(LIBNAME) $(LIB_OBJS:$o=.lo) \
|
|
+ -o $(LIBNAME) $(LIB_OBJS:.o=.lo) \
|
|
-rpath $(INSTALL_PREFIX)$(libdir) \
|
|
-version-info $(NCURSES_MAJOR):$(NCURSES_MINOR) $(SHLIB_LIST)
|
|
|
|
@@ -184,7 +184,7 @@ mostlyclean ::
|
|
clean :: mostlyclean
|
|
-sh -c "if test -n '$x' ; then $(MAKE) clean x=''; fi"
|
|
-rm -rf $(MODEL)/SunWS_cache
|
|
- -$(LIBTOOL_CLEAN) rm -f demo$x $(AUTO_SRC) ../lib/$(LIBNAME) $(LIB_OBJS) $(LIB_OBJS:$o=.lo) $(OBJS_DEMO)
|
|
+ -$(LIBTOOL_CLEAN) rm -f demo$x $(AUTO_SRC) ../lib/$(LIBNAME) $(LIB_OBJS) $(LIB_OBJS:.o=.lo) $(OBJS_DEMO)
|
|
-rm -rf .libs
|
|
|
|
distclean :: clean
|