pkgsrc/comms/hylafax/patches/patch-ap
adam a56bf1eb4a Changes 4.2.1:
* fix CAN-2004-1182: hfaxd client/server authentication
  vulnerability (10 Jan 2005)
* fix possible filename race in tiff2pdf (10 Jan 2005)
* improve modern distinctive ring support, add
  NoAnswerVoice config feature, and enhance third-party
  getty interaction (1, 2 Jan 2005)
* add support for etc/resetmodem (30 Dec 2004)
* fix NOTIFY_FAXMASTER within notify (30 Dec 2004)
* improve tiff2pdf and use it more (29 Dec 2004)
* fix 300 dpi support for some receivers (28 Dec 2004)
* cause faxsetup to double-check and fix attachment encoding
  setup (27 Dec 2004)
* add uuencode support in pollrcvd (27 Dec 2004)
* add support for base64-encode (27 Dec 2004)
* check strftime with arguments, gcc-3.3 fix (23 Dec 2004)
* initialize some variables in some scripts that may not
  be initialzed in setup.cache (23, 27 Dec 2004)
* remove need to have separate "fax" user (22 Dec 2004)
* fix parsing of AT+FCLASS=? response within faxaddmodem
  and probemodem (21 Dec 2004)
* improve multi-line handling within notify (20 Dec 2004)
* improve trap handling in faxaddmodem/probemodem (17 Dec 2004)
* fix hfaxd from rejecting jobs scheduled for the past while
  the killtime is still in the future (15 Dec 2004)
* drop ftp links from received notification e-mail (8 Dec 2004)
* fix dial-and-answer feature (2 Dec 2004)
* add NSF recognition for MFC-3100C (29 Nov 2004)
* fix Class 1 support for services "0,1.0" (26 Nov 2004)
* limit hfaxd jobs cache size (23 Nov 2004)
* fix hfaxd ABOR command and trigger (23 Nov 2004)
* fix error when hfaxd FIFO fills (23 Nov 2004)
* document -age option for recvstats/xferfaxstats (23 Nov 2004)
* add coversheet information into the q-file (23 Nov 2004)
* fix documentation regarding DesiredEC (23 Nov 2004)
* change minsp to minbr for consistency (23 Nov, 2 Dec 2004)
* fix hfaxd problem with file descriptors (23 Nov 2004)
* fix hfaxd from dying on ECONNABORTED (23 Nov 2004)
* add -fpic to DSO build for non-x86 Linux (23 Nov 2004)
* add CALL records to xferfaxlog and LogCalls config (16 Nov 2004)
* fix/implement desireddf in faxsend and faxq (29 Oct 2004)
* fix the filetype output for JPARM DOCUMENTS (14 Oct 2004)
* add SHIELDED_DTMF option for CIDNumber (7 Oct 2004)
* add Class1Resolutions, deprecate Class1ExtendedRes (20 Sep 2004)
* fix a bug in notify when the job is killed (15 Sep 2004)
* initialize supplementary groups when switching
  uid (13 Sep, 8 Dec 2004)
* fix faxsend to retrain after receiving RTP (9 Sep 2004)
* fix tiffcheck unit comparison error (1 Sep 2004)
* fix misconfirmation of some ECM faxes (30 Aug 2004)
* add fax batching support to faxq (30 Aug, 9 Sep 2004)
* ignore garbage after sending TCF data (26 Aug 2004)
* fix truncation of filenames in faxcron (26 Aug 2004)
* add configure support for libtiff 3.7 (25 Aug 2004)
* extend short send-HDLC timeouts (18 Aug 2004)
* add a pause after receiving MCF on non-ECM send sessions (18 Aug 2004)
* fix broken fax polling (17 Aug 2004)
* add several timing enhancements for stressed
  servers (16 Aug, 10, 15 Sep, 14 Oct 2004)
2005-01-27 16:22:37 +00:00

35 lines
1.6 KiB
Text

$NetBSD: patch-ap,v 1.8 2005/01/27 16:22:37 adam Exp $
--- util/Makefile.in.orig 2004-08-16 12:58:22.000000000 +0000
+++ util/Makefile.in
@@ -156,7 +156,7 @@ checkat: checkat.o ${LIBS}
PUTCLIENT = ${INSTALL} -idb ${PRODUCT}.sw.client
PUTSERVER = ${INSTALL} -idb ${PRODUCT}.sw.server
PUTSERV = ${PUTSERVER} -m 755
-PUTSUPD = ${PUTSERVER} -F ${SPOOL}/bin -idb "config(update)"
+PUTSUPD = ${PUTSERVER} -F ${LIBEXEC}/hylafax -idb "config(update)"
PUTSBIN = ${PUTSERVER} -F ${SBIN}
installClient: default
@@ -173,6 +173,7 @@ install: installClient
${PUTSBIN} -m 755 -src xferfaxstats.sh -O xferfaxstats
${PUTSBIN} -m 755 -src recvstats.sh -O recvstats
${PUTSBIN} -m 755 -idb "config(update)" -src faxcron.sh -O faxcron
+ -${MKDIR} -m 755 ${LIBEXEC}/hylafax
${PUTSUPD} -m 755 -src ps2fax.gs.sh -O ps2fax.gs
${PUTSUPD} -m 755 -src ps2fax.dps.sh -O ps2fax.dps
${PUTSUPD} -m 755 -src ps2fax.imp.sh -O ps2fax.imp
@@ -187,9 +188,11 @@ install: installClient
${PUTSUPD} -m 755 -src pollrcvd.sh -O pollrcvd
${PUTSUPD} -m 755 -src mkcover.sh -O mkcover
${PUTSUPD} -m 755 -src wedged.sh -O wedged
- ${PUTSERVER} -F ${SPOOL}/etc -m 444 -idb "config(update)" \
+ -${MKDIR} -m 755 ${PREFIX}/share/hylafax
+ -${MKDIR} -m 755 ${PREFIX}/share/hylafax/etc_template
+ ${PUTSERVER} -F ${PREFIX}/share/hylafax/etc_template -m 444 -idb "config(update)" \
-src ${SRCDIR}/dpsprinter.ps -O dpsprinter.ps
- ${PUTSERVER} -F ${SPOOL}/etc -idb "config(suggest)" \
+ ${PUTSERVER} -F ${PREFIX}/share/hylafax/etc_template -idb "config(suggest)" \
-m 444 -src ${SRCDIR}/cover.templ -O cover.templ
@MAKEDSOINCLUDE@ @MAKELQUOTE@${SRCDIR}/Makefile.@DSO@dso@MAKERQUOTE@