pkgsrc/archivers/ha/patches/patch-ab
asau 6b6c865608 Fix segmentation fault due to time_t being longer than long.
While here, allow building it with standard make.
2013-09-18 20:58:35 +00:00

28 lines
619 B
Text

$NetBSD: patch-ab,v 1.3 2013/09/18 20:58:36 asau Exp $
--- makefile.nix.orig 1995-01-12 07:26:26.000000000 +0000
+++ makefile.nix
@@ -21,10 +21,9 @@
MCH = nix
-CC = gcc
-CPP = $(CC) -E
-CFLAGS = -Wall -O2 -c -I../$(MCH) -I../include
-LDFLAGS = -O2
+#CC = gcc
+#CPP = $(CC) -E
+CFLAGS += -c -I../$(MCH) -I../include
MDEFINES = "CC=$(CC)" "CPP=$(CPP)" "CFLAGS=$(CFLAGS)" "DEFS=$(DEFS)"
SUBDIRS = c $(MCH) include
@@ -46,6 +45,6 @@ clean:
#
# include a dependency file if one exists
#
-ifeq (.depend,$(wildcard .depend))
-include .depend
-endif
+#ifeq (.depend,$(wildcard .depend))
+#include .depend
+#endif