pkgsrc/graphics/magicpoint/patches/patch-ab
taca 2615325c03 Update magicpoint to 1.13a.
* Fix build error with xft2 option and graphics/freetype-lib package is
  installed.  Shoud be fix PR pkg/32656.
* Refering PR pkg/38552 adpot some of patches.
* Move PKG_OPTIONS related item to options.mk.
* More pkgsrc clean up.
* Try to reduce compile warnings.


What's new in 1.13a?

    * m17n library support enhancement
    * MacOS support enhancement
    * add new environment variable MGPRC for the path of the .mgprc file.
    * add "psfont" directive to specify the font used by mgp2ps
    * add -g option for mgp2ps to allow users to adjust line distanc
    * add -zoomonclk option for newimage
    * allow to handle gif format images by default
    * many bug fixes

      Dedication

      Magicpoint 1.13a is dedicated to the memory of Dr. Jun-ichiro
      "itojun" Hagino, who was known for his enormous contribution to
      the Internet and the Open Source Software community. He was the
      developer of Magicpoint from its infancy. Magicpoint could not
      exist without his devoted work.

What's new in 1.12a?

    * add %tsystem directive which might be more stable than %xsystem
    * add -rotate option for newimage
    * allow to use non-ASCI filename in slides (use -U to enable this feature)
    * many bug fixes
2008-09-10 13:32:47 +00:00

53 lines
1.5 KiB
Text

$NetBSD: patch-ab,v 1.4 2008/09/10 13:32:47 taca Exp $
--- mgp.h.orig 2008-01-19 02:43:20.000000000 +0900
+++ mgp.h
@@ -64,7 +64,9 @@
#ifdef USE_XFT2
#include <ft2build.h>
#include FT_FREETYPE_H
-#include <fontconfig/fontconfig.h>
+#include FT_CONFIG_CONFIG_H
+#include <freetype2/freetype/fterrors.h>
+#include <freetype2/freetype/freetype.h>
#include <X11/Xft/Xft.h>
#ifdef HAVE_ICONV
#include <iconv.h>
@@ -308,6 +310,12 @@ struct ctrl_pcache {
struct ctrl {
u_char ct_op;
u_char ct_flag;
+ enum {
+ CTRL_DOUBLE, CTRL_INT, CTRL_INT2, CTRL_INT3,
+ CTRL_LONG, CTRL_CHAR, CTRL_CHAR2, CTRL_IMAGE,
+ CTRL_GRAD, CTRL_BAR, CTRL_ARGS, CTRL_ICON,
+ CTRL_AREA, CTRL_PCACHE, CTRL_VOID
+ } ct_type;
u_int ct_page;
struct ctrl *ct_next;
union {
@@ -745,6 +753,11 @@ extern int get_regid __P((char *));
extern void draw_line_itemsize __P((struct render_state *, int, int, int));
extern void draw_line_start __P((struct render_state *));
extern void draw_line_end __P ((struct render_state *));
+#ifdef USE_IMLIB
+int search_zimage(int, int, int);
+void zoomin_zimage(int);
+void zoomout_zimage(int);
+#endif
#ifdef USE_M17N
extern int obj_new_mtext __P((struct render_state *, int, int,
@@ -843,6 +856,12 @@ extern void usleep __P((u_int));
#define COLOR_BUGFIX
#endif
+#ifdef MNG
+/*mng.c*/
+void mngload(char *, int, int, int, int);
+void mngpreload(struct render_state *, char *, int *, int *);
+#endif
+
#ifdef USE_M17N
/*m17n.c*/
extern void M17N_init __P((void));