3fd37557f7
* Set LICENSE. Changelog: http://mozilla.6506.n7.nabble.com/ANNOUNCE-NSPR-4-10-Release-td280660.html -------------- NSPR 4.10 has the following bug fixes: * Bug 331169: Obviate PR_Sleep before PR_GetConnectStatus on Windows. Fixed by Brian Smith. * Bug 687033: Support Windows/arm. Fixed by Makoto Kato (partially checked in). * Bug 687033: Remove WINCE and Win9x support partially. * Bug 844513: Add AddressSanitizer (ASan) memory check annotations to PLArena. Fixed by Mats Palmgren. * Bug 849089: Simple changes to make NSPR's configure.in work with the current version of autoconf. * Bug 856196: Fix compiler warnings and clean up code in NSPR 4.10. * Bug 859066: Fix warning in nsprpub/pr/src/misc/prnetdb.c. * Bug 859830: Deprecate ANDROID_VERSION in favor of android/api-level.h. Fixed by Vicamo Yang. * Bug 861434: Make PR_SetThreadPriority() change priorities relatively to the main process instead of using absolute values on Linux. Fixed by Gabriele Svelto. * Bug 871064L: _PR_InitThreads() should not call PR_SetThreadPriority.
31 lines
948 B
Text
31 lines
948 B
Text
$NetBSD: patch-ag,v 1.5 2013/07/20 08:57:20 ryoon Exp $
|
|
|
|
--- nsprpub/pr/include/md/_freebsd.h.orig 2012-03-06 13:13:51.000000000 +0000
|
|
+++ nspr/pr/include/md/_freebsd.h
|
|
@@ -47,7 +47,7 @@
|
|
#define _PR_HAVE_LARGE_OFF_T
|
|
|
|
#if defined(_PR_PTHREADS)
|
|
-#if __FreeBSD_version >= 400008
|
|
+#if defined(__DragonFly__) || __FreeBSD_version >= 400008
|
|
/*
|
|
* libc_r before this version of FreeBSD doesn't have poll().
|
|
* Although libc has poll(), it is not thread-safe so we can't
|
|
@@ -56,7 +56,7 @@
|
|
#define _PR_POLL_AVAILABLE
|
|
#endif
|
|
#else
|
|
-#if __FreeBSD_version >= 300000
|
|
+#if defined(__DragonFly__) || __FreeBSD_version >= 300000
|
|
#define _PR_POLL_AVAILABLE
|
|
#define _PR_USE_POLL
|
|
#endif
|
|
@@ -65,7 +65,7 @@
|
|
#define _PR_HAVE_SYSV_SEMAPHORES
|
|
#define PR_HAVE_SYSV_NAMED_SHARED_MEMORY
|
|
|
|
-#if __FreeBSD_version >= 400014
|
|
+#if defined(__DragonFly__) || __FreeBSD_version >= 400014
|
|
#define _PR_INET6
|
|
#define _PR_HAVE_INET_NTOP
|
|
#define _PR_HAVE_GETHOSTBYNAME2
|