pkgsrc/security/zoneminder/patches/patch-scripts_zm_in
dsainty 3205b33802 Update ZoneMinder from 1.25.0 to 1.28.1.
Numerous changes, documented at:
 https://github.com/ZoneMinder/ZoneMinder/releases

Addresses two security advisories:

  https://github.com/ZoneMinder/ZoneMinder/releases/tag/v1.28.0
  http://secunia.com/advisories/62918/

Pkgsrc changes:

patch-src_zm_signal_h is no longer necessary because zm_signal.h uses
HAVE_EXECINFO_H.

patch-src_zmf_cpp appears to be applied upstream.

patch-configure_ac no longer needs to set PATH_BUILD to
PREFIX/share/zoneminder, so that zmupdate.pl can locate the database build
scripts as installed files.  Upstream has now implemented this via the
ZM_PATH_DATA entry in zm.conf, and adds a ZM_PATH_DATA/db subdirectory.

src/Makefile.am no longer setuid's zmfix, as zmfix was removed from
ZoneMinder 1.26.6.

The code now uses clock_gettime(), which on some systems (like Linux), calls
for -lrt.  Since the build system isn't aware of this, but Pkgsrc is, just set
PTHREAD_AUTO_VARS=yes.

The PHP code now uses PDO for DB access, but it looks like there are some
straggling dependencies on the raw MySQL driver, so both are pulled in.
2015-04-05 08:51:08 +00:00

51 lines
1.2 KiB
Text

$NetBSD: patch-scripts_zm_in,v 1.3 2015/04/05 08:51:08 dsainty Exp $
/etc/rc.d/init.d/functions doesn't commonly exist.
The LOCKFILE feature appears unused, and requires a /var/lock/subsys directory
we don't have.
--- scripts/zm.in.orig 2015-02-05 15:52:37.000000000 +1300
+++ scripts/zm.in 2015-04-01 19:13:32.876553811 +1300
@@ -7,12 +7,12 @@
# For systemd environments, use the ZoneMinder systemd unit file instead
# Source function library.
-. /etc/rc.d/init.d/functions
+#. /etc/rc.d/init.d/functions
prog=ZoneMinder
ZM_CONFIG="@ZM_CONFIG@"
pidfile="@ZM_RUNDIR@"
-LOCKFILE=/var/lock/subsys/zm
+#LOCKFILE=/var/lock/subsys/zm
loadconf()
{
@@ -54,7 +54,7 @@
RETVAL=$?
[ $RETVAL = 0 ] && success || failure
echo
- [ $RETVAL = 0 ] && touch $LOCKFILE
+ #[ $RETVAL = 0 ] && touch $LOCKFILE
return $RETVAL
}
@@ -66,7 +66,7 @@
RETVAL=$?
[ $RETVAL = 0 ] && success || failure
echo
- [ $RETVAL = 0 ] && rm -f $LOCKFILE
+ #[ $RETVAL = 0 ] && rm -f $LOCKFILE
}
zmstatus()
@@ -107,7 +107,7 @@
result=`$ZM_PATH_BIN/zmdc.pl check`
if [ "$result" = "running" ]; then
$ZM_PATH_BIN/zmdc.pl shutdown > /dev/null
- rm -f $LOCKFILE
+ #rm -f $LOCKFILE
start
fi
;;