pkgsrc/graphics/geomview/patches/patch-ak
jschauma 64c9904eed This package used to conflict with ImageMagick since they both install a
program called "animate".  By renaming the program to "gv-animate" in this
version, we can resolve the conflict.  Bump PKG_REVISION for better
compatibility.
2003-07-03 17:38:27 +00:00

45 lines
1.5 KiB
Text

$NetBSD: patch-ak,v 1.1 2003/07/03 17:38:28 jschauma Exp $
Rename 'animate' to 'gv-animate' to avoid conflict with ImageMagick's
'animate' program.
--- src/bin/animate/Makefile.in.orig Thu Jul 3 13:09:48 2003
+++ src/bin/animate/Makefile.in Thu Jul 3 13:11:48 2003
@@ -98,9 +98,9 @@
INCLUDES = $(default_includes) $(MOTIFINCLUDE)
SUBDIRS = interface
-EXTRA_DIST = animate.1
+EXTRA_DIST = gv-animate.1
-module_PROGRAMS = animate
+module_PROGRAMS = gv-animate
animate_SOURCES = animate.c xanimate.c glob.c animate.h glob.h xanimate.h
LDADD = ../../lib/mib/libmib.a $(MOTIFLIBS) $(XMULIBS) $(XLIBS) $(MATHLIB)
@@ -194,8 +194,8 @@
maintainer-clean-compile:
-animate: $(animate_OBJECTS) $(animate_DEPENDENCIES)
- @rm -f animate
+gv-animate: $(animate_OBJECTS) $(animate_DEPENDENCIES)
+ @rm -f gv-animate
$(LINK) $(animate_LDFLAGS) $(animate_OBJECTS) $(animate_LDADD) $(LIBS)
install-moduleDATA: $(module_DATA)
@@ -416,12 +416,12 @@
.geomview-animate:
- echo '(emodule-define "Animator" "animate")' > .geomview-animate
+ echo '(emodule-define "Animator" "gv-animate")' > .geomview-animate
# Populate local "modules" directory, allowing animate to run in the build dir.
all-local:
$(top_srcdir)/mkmodulesdir $(top_builddir)
- echo '(emodule-define "Animator" "$(subdir)/animate")' > $(top_builddir)/modules/.geomview-animate
+ echo '(emodule-define "Animator" "$(subdir)/gv-animate")' > $(top_builddir)/modules/.geomview-animate
# noinst_SCRIPTS = install-geomview-dotfile
# bin_SCRIPTS = .geomview-animate