pkgsrc/mail/exim3/patches/patch-aa
joerg d5a1d5c4ff Use SUBST framework instead of FILES_SUBST_SED. Rename temporary file
from Makefile.NetBSD to Makefile.pkgsrc (cosmetic only). Use PERL5
instead of PREFIX/bin/perl when looking for Perl interpreter.
2006-01-20 23:09:42 +00:00

104 lines
3.4 KiB
Text

$NetBSD: patch-aa,v 1.2 2006/01/20 23:09:42 joerg Exp $
--- Local/Makefile.pkgsrc.orig Fri May 7 18:36:39 2004
+++ Local/Makefile.pkgsrc
@@ -78,7 +78,7 @@
# CHGRP_COMMAND=/usr/bin/chgrp
# MV_COMMAND=/bin/mv
# RM_COMMAND=/bin/rm
-# PERL_COMMAND=/usr/bin/perl
+PERL_COMMAND=@PERL5@
# The following macro can be used to change the command for building a library
@@ -92,8 +92,8 @@
# appropriate code is included in the binary. You then need to set up the
# runtime configuration to make use of the mechanism(s) selected.
-# AUTH_CRAM_MD5=yes
-# AUTH_PLAINTEXT=yes
+AUTH_CRAM_MD5=yes
+AUTH_PLAINTEXT=yes
# The binary directory: This variable defines where the exim binary will be
@@ -103,7 +103,7 @@
# installed in this directory. There is no default for this variable built into
# the source files; it must be set in one of the local configuration files.
-BIN_DIRECTORY=/usr/exim/bin
+BIN_DIRECTORY=@PREFIX@/sbin
# The default distribution of Exim contains only the plain text form of the
@@ -121,14 +121,14 @@ BIN_DIRECTORY=/usr/exim/bin
# files. Both the name of the command and the suffix that it adds to files
# need to be defined here. See also the EXICYCLOG_MAX configuration.
-COMPRESS_COMMAND=/opt/gnu/bin/gzip
+COMPRESS_COMMAND=@GZIP_CMD@
COMPRESS_SUFFIX=gz
# If the exigrep utility is fed compressed log files, it tries to uncompress
# them using this command.
-ZCAT_COMMAND=/opt/gnu/bin/zcat
+ZCAT_COMMAND=@GZCAT@
# The runtime configuration file: This variable defines where Exim's runtime
@@ -137,7 +137,7 @@ ZCAT_COMMAND=/opt/gnu/bin/zcat
# location of all other runtime files and directories can be changed in the
# runtime configuration file.
-CONFIGURE_FILE=/usr/exim/configure
+CONFIGURE_FILE=@PKG_SYSCONFDIR@/configure
# In some installations there may be multiple machines sharing file systems,
@@ -243,7 +243,7 @@ EXICYCLOG_MAX=10
# are defaulted in the OS/Makefile-Default file, and can be overridden
# in local OS-specific make files.
-EXIM_MONITOR=eximon.bin
+# EXIM_MONITOR=eximon.bin
# Compiling in support for embedded Perl: If you want to be able to
@@ -286,7 +286,7 @@ EXIM_MONITOR=eximon.bin
# "panic", or "reject" to form the final file name. For example, some
# installations may want something like this:
-# LOG_FILE_PATH=/var/log/exim_%slog
+LOG_FILE_PATH=/var/log/exim/%slog
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
@@ -411,7 +411,7 @@ LOOKUP_LSEARCH=yes
# the file name, allowing sites that run two separate daemons to distinguish
# them. Some installations may want something like this
-# PID_FILE_PATH=/var/lock/exim%s.pid
+PID_FILE_PATH=/var/run/exim%s.pid
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
# (see SPOOL_DIRECTORY below) with the name "exim-daemon.pid" for the standard
@@ -460,7 +460,7 @@ ROUTER_QUERYPROGRAM=yes
# uid and gid.
# Many installations will want something like this:
-# SPOOL_DIRECTORY=/var/spool/exim
+SPOOL_DIRECTORY=/var/spool/exim
# Others may prefer to keep all Exim things under one directory:
# SPOOL_DIRECTORY=/usr/exim/spool
@@ -567,7 +567,7 @@ TRANSPORT_SMTP=yes
# This one is special-purpose, and commonly not required, so do not include
# it by default.
-# TRANSPORT_LMTP=yes
+TRANSPORT_LMTP=yes
# TCP wrappers: If you want to use tcpwrappers from within Exim, uncomment