pkgsrc/lang/guile/patches/patch-ah
gdt 93c2fed2cc Restore a fixed version of patch-ah. While -R was in the string, it
was there because guile was built against gmp etc. from /usr/pkg, not
present to let programs find -lguile.  Therefore, add in rpath for
$(libdir) when we add in -L for libdir.

This looks ok to me, but I will be away AFK most of the day, so feel
free to remove the line in distinfo and re-commit if this turns out to
be bad.
2008-12-15 15:26:47 +00:00

14 lines
517 B
Text

$NetBSD: patch-ah,v 1.6 2008/12/15 15:26:47 gdt Exp $
--- guile-config/guile-config.in.orig 2008-12-04 13:30:41.000000000 -0500
+++ guile-config/guile-config.in
@@ -154,7 +154,8 @@
(if (or (string=? libdir "/usr/lib")
(string=? libdir "/usr/lib/"))
""
- (string-append "-L" (get-build-info 'libdir)))
+ (string-append "-L" (get-build-info 'libdir)
+ " -Wl,-R" (get-build-info 'libdir)))
"-lguile -lltdl"
(string-join other-flags)