pkgsrc/graphics/gdk-pixbuf/patches/patch-ad
wiz 7fc3179980 Update to 0.22. Remove dependency on auto* by adding patches for the
generated files.

(Not portability) changes since 0.18:
* Made the GIF loader handle animations with frames whose bounds go outside
  of the base image's bounds (Federico).
* Made the GIF loader handle zero-sized frames that GifBuilder and
  similar crap spits sometimes (Federico).
* The PNM loader doesn't abort() anymore if it cannot allocate memory
  (Federico).
* Fixed a g_object_unref() -> gdk_pixbuf_unref() thinko (Federico).
* Merged the patch from Red Hat Linux 8.0 to fix the crash on
  corrupted/short GIFs - Ximian 29040 (patch by Elliot Lee).
* Fixed the RGB 565 LSB -> MSB case in gdk-pixbuf-drawable - 79463
  (Federico).
* Fixed the update region notification in the BMP loader (Federico).
* Merged the BMP loader changes from GTK+ HEAD -- check all reallocs,
  fix 16bpp BI_RGB thinko, properly handle BI_RLE4 and skips and jumps
  (changes by Matthias Clasen).
* Merged the ICO loader changes from GTK+ HEAD (changes by Matthias
  Clasen).
* Merged changes from gtk+/gdk-pixbuf HEAD into the JPEG loader --
  fixes CMYK JPEG problems (changes by Matthias Clasen).
2003-01-15 21:03:25 +00:00

20 lines
631 B
Text

$NetBSD: patch-ad,v 1.5 2003/01/15 21:03:26 wiz Exp $
--- gdk-pixbuf/pixops/Makefile.in.orig Wed Dec 18 23:19:33 2002
+++ gdk-pixbuf/pixops/Makefile.in
@@ -381,6 +372,15 @@ all-redirect all-am all installdirs most
distclean-generic clean-generic maintainer-clean-generic clean \
mostlyclean distclean maintainer-clean
+
+ifeq (m68k,$(findstring m68k,$(host_alias)))
+pixops.o: pixops.c
+ $(COMPILE) -O -c $<
+
+pixops.lo: pixops.c
+ $(LIBTOOL) --mode=compile $(COMPILE) -O -c $<
+
+ endif
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.