pkgsrc/math/scilab/patches/patch-am
dmcmahill 9d3ebd2e9e update to scilab-3.0
Main Changes Scilab 2.7 -> 3.0
                     ==============================
NEW FUNCTIONALITIES
===================
- continue instruction added
- [a(i,j),b(..),..]=foo(..) syntax is now handled
- arpack algorithms for sparse matrix eigenvalues/eigenvectors computation added
- Levenberg-Marquardt algorithm of Minpack used to define function lsqrsolve
- New graphics mode improved
- beta and legendre function added (thanks to B Pincon)
- Scicos has been extended to handle non causal systems description (supported by RNTL)
- Matlab to Scilab translator has been re-written, and extended to current Matlab syntax.

OTHERS IMPROVEMENTS
===================
- Better discontinuities handling in Scicos
- More efficient number parsing (thanks to B Pincon)
- More efficient 3D Zoom (thanks to E Segre)
- Improved scipad, shortcuts, language handling, colorization, bug fixes.. (thanks to E Segre)
- for loop variable is no more removed at the end of the loops
- figure sizes are now taken into account in Postscript export
- Windows GUI improved
- Graphic windows refresh improved under Windows
- Scilab has been adapated to IA64 architecture
- Helvetica (Arial on Windows) fonts added (corresponding font identifiers are
  from 6 to 9) (thanks to B Pincon)
- N dimensionnal matrices efficiency improved (thanks to B Pincon)
- logical expressions shortcuts handled in if
- cd, ls, clc, clf, tohome functions added
- functions with no argument can be called without () if called as a command
2004-07-15 04:00:46 +00:00

13 lines
511 B
Text

$NetBSD: patch-am,v 1.7 2004/07/15 04:00:47 dmcmahill Exp $
--- examples/interface-multi-so/lib/Makefile.orig Mon Jul 8 10:22:28 2002
+++ examples/interface-multi-so/lib/Makefile
@@ -18,7 +18,7 @@ tests : all
clean ::
@echo Cleaning
@$(RM) -f -r *.o *.lo *.la *.so *.dll *.sl *.a *.dia .job.sce so_locations
- @$(RM) -f -r .libs f3cloader.sce f3cmake f3floader.sce f3fmake
+ @$(RM) -f -r .libs f3cloader.sce f3cmake f3floader.sce f3fmake loader.sce
distclean:: clean
@$(RM) -f *.dia *_gateway.c