01c69b1c61
This addresses the security problem CVE-2008-4311. For more details, read http://lists.freedesktop.org/archives/dbus/2008-December/010769.html
35 lines
1.6 KiB
Text
35 lines
1.6 KiB
Text
$NetBSD: patch-aa,v 1.10 2009/01/07 19:11:36 wiz Exp $
|
|
|
|
--- bus/Makefile.in.orig 2008-12-18 21:47:13.000000000 +0100
|
|
+++ bus/Makefile.in
|
|
@@ -415,9 +415,10 @@ target_vendor = @target_vendor@
|
|
top_build_prefix = @top_build_prefix@
|
|
top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
-configdir = $(sysconfdir)/dbus-1
|
|
+etcconfigdir = $(sysconfdir)/dbus-1
|
|
+configdir = $(datadir)/examples/@PACKAGE@
|
|
INCLUDES = -I$(top_srcdir) $(DBUS_BUS_CFLAGS) @PIE_CFLAGS@ \
|
|
- -DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
|
|
+ -DDBUS_SYSTEM_CONFIG_FILE=\""$(etcconfigdir)/system.conf"\" \
|
|
-DDAEMON_NAME=\"dbus-daemon\" -DDBUS_COMPILATION
|
|
|
|
EFENCE =
|
|
@@ -1294,16 +1295,13 @@ install-data-hook:
|
|
chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
|
|
fi
|
|
$(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
|
|
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
|
|
- $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
|
|
- $(mkinstalldirs) $(DESTDIR)$(configdir)/session.d
|
|
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
|
|
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/system-services
|
|
$(mkinstalldirs) $(DESTDIR)$(libexecdir)/dbus-1
|
|
$(INSTALL_PROGRAM) dbus-daemon-launch-helper $(DESTDIR)$(libexecdir)
|
|
if test `id -u` -eq 0; then \
|
|
chown root:$(DBUS_USER) $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
|
|
- chmod 4750 $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
|
|
+ chmod 4550 $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
|
|
else \
|
|
echo "Not installing $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper binary setuid!"; \
|
|
echo "You'll need to manually set permissions to root:$(DBUS_USER) and permissions 4750"; \
|