5731bb3633
and has no list of changes. Restructure packages to use a common Makefile and patch directory. Set the maintainer to me, as this is a non-trivial change. Compile in the samba vfs code.
31 lines
1.2 KiB
Text
31 lines
1.2 KiB
Text
$NetBSD: patch-af,v 1.11 2000/10/19 23:31:18 jlam Exp $
|
|
|
|
--- Makefile.in.orig Mon Jul 3 10:31:57 2000
|
|
+++ Makefile.in
|
|
@@ -5,14 +5,15 @@
|
|
@MCFGR@@MCF@
|
|
|
|
foreigndirs=pc
|
|
-codedirs=vfs lib doc slang gtkedit edit src gnome new_icons icons idl syntax
|
|
-unixdirs=intl $(codedirs) doc-gnome @POSUB@
|
|
+codedirs=vfs lib doc slang gtkedit edit src new_icons icons syntax @gnomecodedirs@
|
|
+unixdirs=intl $(codedirs) @gnomeunixdirs@ @POSUB@
|
|
alldirs=$(unixdirs) $(foreigndirs)
|
|
subdirs=$(alldirs)
|
|
|
|
INSTALL = @INSTALL@
|
|
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
|
INSTALL_DATA = @INSTALL_DATA@
|
|
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
|
|
|
DISTMAIN = configure configure.in NEWS README INSTALL INSTALL.FAST \
|
|
Makefile.in FAQ COPYING create_vcs install-sh \
|
|
@@ -45,7 +46,7 @@
|
|
install: installdirs
|
|
@for I in $(unixdirs); do cd $$I; $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1; cd ..; done
|
|
$(INSTALL_DATA) $(srcdir)/FAQ $(DESTDIR)$(mclibdir)/FAQ
|
|
- $(INSTALL_PROGRAM) mcfn_install $(DESTDIR)$(suppbindir)/mcfn_install
|
|
+ $(INSTALL_SCRIPT) mcfn_install $(DESTDIR)$(suppbindir)/mcfn_install
|
|
chmod +x $(DESTDIR)$(suppbindir)/mcfn_install
|
|
@echo "Please verify that the configuration values are correctly"
|
|
@echo "set in the mc.ext file in $(mclibdir)"
|