pkgsrc/databases/postgresql80/patches/patch-af
jlam c27abb4a87 Several changes to the postgresql80-* packages:
* Become maintainer for the postgresql80-* packages (ok'd by recht)

* Libtoolize postgresql80 build so that the shared libraries and
  loadable shared modules are built using libtool.  This should make
  PostgreSQL 8.0.x in pkgsrc build correctly on more pkgsrc-supported
  platforms.  This is accomplished with the Makefile.libtool file
  which replaces the Makefile.shlib file in the PostgreSQL distribution.

* Add libltdl modifications from the postgresql74-* packages so that
  this can work on Interix (untested).

* Fix some mismatches between static function declarations and their
  subsesquent definitions in the src/timezone module.  Fixes provided
  by Georg Schwarz.

* Convert PGSQL_USE_HIER into the PKG_OPTION "pgsql-hier-query", and
  teach both postgresql80-client and postgresql80-server to use it.

* Use BUILDLINK_TRANSFORM's "rm" action to remove unwanted compiler
  flags.

* Remove zlib/buildlink3.mk from postgresql80-client/buildlink3.mk
  as zlib is only used by the pg_dump client.

* Convert some files in files/* into patches that can be fed back
  to the PostgreSQL team.

* Install data and documentation files into share/postgresql instead
  of share/postgresql80 -- it's only possible to install one PostgreSQL
  version at a time in pkgsrc, and the new paths more closely match
  the rest of the installation paths.

* Add more mirrors to the MASTER_SITES list, and add a new variable
  POSTGRESQL_MIRRORS_SORT that has the same syntax as MASTER_SORT that
  can help people pick a nearby mirror.

* Nuke references to libpgtcl which is no longer distributed as part
  of a standard PostgreSQL installation as of version 8.0.

* Provide better documentation for Makefile.custom.

* Avoid linking in the pthread library in the correct way on NetBSD
  by setting DLOPEN_REQUIRE_PTHREADS=no.  Also, provide better
  documentation on why we can't enable thread-safety in the PostgreSQL
  libraries on NetBSD (at least for now).

* Preliminary support for installing postgresql80-* into a separate
  subdirectory under ${LOCALBASE} so possibly allow for multiple
  installations of PostgreSQL on the same machine.  Note that THIS
  DOES NOT WORK YET.

* Update the hierarchical-queries patch to "8.0.3-0.5.5" which fixes
  a bug which was crashing the backend when PRIOR was used in the
  target list.  The _level_ column is no longer automatically added
  to target list.  This makes it possible to use hierarchical queries
  as IN subqueries.  To get _level_ back you just have to explicitly
  mention it in target list.

Bump the following PKGREVISIONs:

	postgresql80-client	-> 2
	postgresql80-server	-> 2
	postgresql80		-> 1
2005-08-05 19:43:44 +00:00

31 lines
1.6 KiB
Text

$NetBSD: patch-af,v 1.1 2005/08/05 19:43:45 jlam Exp $
--- src/timezone/localtime.c.orig 2004-11-01 16:34:44.000000000 -0500
+++ src/timezone/localtime.c
@@ -109,19 +109,19 @@ struct rule
static long detzcode(const char *codep);
static const char *getzname(const char *strp);
-static const char *getnum(const char *strp, int *nump, int min, int max);
+static const char *getnum(const char *strp, int *nump, const int min, const int max);
static const char *getsecs(const char *strp, long *secsp);
static const char *getoffset(const char *strp, long *offsetp);
static const char *getrule(const char *strp, struct rule * rulep);
static void gmtload(struct state * sp);
-static void gmtsub(const pg_time_t *timep, long offset, struct pg_tm * tmp);
-static void localsub(const pg_time_t *timep, long offset, struct pg_tm * tmp);
-static void timesub(const pg_time_t *timep, long offset,
+static void gmtsub(const pg_time_t *timep, const long offset, struct pg_tm * tmp);
+static void localsub(const pg_time_t *timep, const long offset, struct pg_tm * tmp);
+static void timesub(const pg_time_t *timep, const long offset,
const struct state * sp, struct pg_tm * tmp);
-static pg_time_t transtime(pg_time_t janfirst, int year,
- const struct rule * rulep, long offset);
+static pg_time_t transtime(const pg_time_t janfirst, const int year,
+ const struct rule * rulep, const long offset);
static int tzload(const char *name, struct state * sp);
-static int tzparse(const char *name, struct state * sp, int lastditch);
+static int tzparse(const char *name, struct state * sp, const int lastditch);
static struct state lclmem;
static struct state gmtmem;