pkgsrc/databases/postgresql80/patches/patch-ag
jlam c27abb4a87 Several changes to the postgresql80-* packages:
* Become maintainer for the postgresql80-* packages (ok'd by recht)

* Libtoolize postgresql80 build so that the shared libraries and
  loadable shared modules are built using libtool.  This should make
  PostgreSQL 8.0.x in pkgsrc build correctly on more pkgsrc-supported
  platforms.  This is accomplished with the Makefile.libtool file
  which replaces the Makefile.shlib file in the PostgreSQL distribution.

* Add libltdl modifications from the postgresql74-* packages so that
  this can work on Interix (untested).

* Fix some mismatches between static function declarations and their
  subsesquent definitions in the src/timezone module.  Fixes provided
  by Georg Schwarz.

* Convert PGSQL_USE_HIER into the PKG_OPTION "pgsql-hier-query", and
  teach both postgresql80-client and postgresql80-server to use it.

* Use BUILDLINK_TRANSFORM's "rm" action to remove unwanted compiler
  flags.

* Remove zlib/buildlink3.mk from postgresql80-client/buildlink3.mk
  as zlib is only used by the pg_dump client.

* Convert some files in files/* into patches that can be fed back
  to the PostgreSQL team.

* Install data and documentation files into share/postgresql instead
  of share/postgresql80 -- it's only possible to install one PostgreSQL
  version at a time in pkgsrc, and the new paths more closely match
  the rest of the installation paths.

* Add more mirrors to the MASTER_SITES list, and add a new variable
  POSTGRESQL_MIRRORS_SORT that has the same syntax as MASTER_SORT that
  can help people pick a nearby mirror.

* Nuke references to libpgtcl which is no longer distributed as part
  of a standard PostgreSQL installation as of version 8.0.

* Provide better documentation for Makefile.custom.

* Avoid linking in the pthread library in the correct way on NetBSD
  by setting DLOPEN_REQUIRE_PTHREADS=no.  Also, provide better
  documentation on why we can't enable thread-safety in the PostgreSQL
  libraries on NetBSD (at least for now).

* Preliminary support for installing postgresql80-* into a separate
  subdirectory under ${LOCALBASE} so possibly allow for multiple
  installations of PostgreSQL on the same machine.  Note that THIS
  DOES NOT WORK YET.

* Update the hierarchical-queries patch to "8.0.3-0.5.5" which fixes
  a bug which was crashing the backend when PRIOR was used in the
  target list.  The _level_ column is no longer automatically added
  to target list.  This makes it possible to use hierarchical queries
  as IN subqueries.  To get _level_ back you just have to explicitly
  mention it in target list.

Bump the following PKGREVISIONs:

	postgresql80-client	-> 2
	postgresql80-server	-> 2
	postgresql80		-> 1
2005-08-05 19:43:44 +00:00

15 lines
657 B
Text

$NetBSD: patch-ag,v 1.1 2005/08/05 19:43:45 jlam Exp $
--- src/timezone/private.h.orig 2004-08-29 01:07:02.000000000 -0400
+++ src/timezone/private.h
@@ -66,8 +66,8 @@ extern int unlink(const char *filename);
extern char *icalloc(int nelem, int elsize);
extern char *icatalloc(char *old, const char *new);
extern char *icpyalloc(const char *string);
-extern char *imalloc(int n);
-extern void *irealloc(void *pointer, int size);
+extern char *imalloc(const int n);
+extern void *irealloc(void *pointer, const int size);
extern void icfree(char *pointer);
extern void ifree(char *pointer);
extern char *scheck(const char *string, const char *format);