pkgsrc/multimedia/lsdvd/patches/patch-aa
xtraeme 06e71c2525 Update to 0.16:
12/12/05 - 0.16

Addition of #include <stdint.h> to support newer libdvdread versions.
Abstraction of code to new generic interface.

15/10/04 - 0.15

abstraction of dvd contents to new struct.
addition of xml output.
additional -O option.
stream ids and osd palette added.
2006-08-24 09:58:14 +00:00

23 lines
799 B
Text

$NetBSD: patch-aa,v 1.3 2006/08/24 09:58:15 xtraeme Exp $
--- configure.in.orig 2006-08-24 11:53:41.000000000 +0200
+++ configure.in 2006-08-24 11:55:34.000000000 +0200
@@ -3,6 +3,7 @@
AM_INIT_AUTOMAKE(lsdvd, 0.16)
CFLAGS="$CFLAGS -g -D_FILE_OFFSET_BITS=64"
AC_PROG_CC
+AC_CHECK_HEADERS([stdint.h inttypes.h])
if eval "test x$GCC = xyes"; then # Enable warnings when using GCC
CFLAGS="$CFLAGS -W -Wall"
@@ -10,8 +11,8 @@
AC_CHECK_LIB(dvdread, DVDOpen, , AC_MSG_ERROR([libdvdread not found!]))
AC_MSG_CHECKING([for dvdread/ifo_read.h])
-AC_TRY_COMPILE([#include <dvdread/ifo_read.h>
- #include <stdint.h>], ,
+AC_TRY_COMPILE([#include <stdint.h>
+ #include <dvdread/ifo_read.h>], ,
AC_MSG_RESULT([yes]),
AC_MSG_RESULT([no])
AC_MSG_ERROR([Header files for dvdread not found]))