bc89da4037
Changes since 2.21b: * Added some Microsoft MIME types (Kevin Day). * Switch htpasswd from using tmpnam to mkstemp. * Rewrote figure_mime() to do binary search. * Removed the x- from gzip and compress in mime_encodings.txt. * Added rudimentary option to set cache-control headers. * Simplified the IPv6 ifdefs. * Allow filenames with ? in them (Cameron Gregory). * Some improvements to the mmap cache - added a "panic mode" if you run out of address space, added DESIRED_MAX_MAPPED_BYTES config.h option. * Lowered OCCASIONAL_TIME from five minutes to two minutes. * Fix CGI variable AUTH_TYPE (Alexandre CHERIF). * Split clear_connection() into two routines, one which sends a possible buffered response and the other which ignores such (David Burgess). * Remove /./ in de_dotdot() (Dana Dahlstrom). * Shortened LINGER_TIME from two seconds to half a second. * Changed some write() calls to httpd_write_fully(), as suggested by Neale Pickett. * Changed the non-mmap() read() call in mmc.c to httpd_read_fully(), as suggested by Cameron Gregory. * Added an madvise(MADV_SEQUENTIAL) call in mmc.c. * Added .xhtml and .xht to mime_types.txt (suggested by Dave Hodder). * Added index.xhtml and index.xht to INDEX_NAMES (suggested by Dave Hodder). * Got rid of the custom-jiggered syslog.c, now we just use the standard system version. Also added a paragraph in the man page about the syslogd flags needed to make syslogging work from inside a chroot tree. * Added some OpenOffice MIME types (Dave Hodder). * Lowered the default DESIRED_MAX_MAPPED_FILES from 2000 to 1000. * Set up accept filters after listen() (Kris Spinka). * Preserve query string when doing a missing-slash directory redirect. * Special-case logging to '-' as stdout (Matt Armstrong). * Added -s to usage line (Pavel Janík). * Fix for security hole that exposed contents of .htpasswd in some cases (noticed by zeno@cgisecurity.com). * Allow (and ignore) extra fields in .htpasswd files. * Added some calls to shutdown() in strategic places. * Added a timer-kill of the CGI interpose input and output process. These processes also now close the listen fd(s). * Fixed rare file descriptor leak, when we get an unknown sockaddr family (George Schlossnagle). * Put virtual hostname in non-local referer syslog (Craig Leres). * Added a P3P server privacy header setting (Henrik Schack Jensen). And lots of other bug fixes.
34 lines
1,000 B
Text
34 lines
1,000 B
Text
$NetBSD: patch-ac,v 1.6 2002/06/16 19:10:26 wiz Exp $
|
|
|
|
--- cgi-src/Makefile.in.orig Mon Nov 12 22:52:00 2001
|
|
+++ cgi-src/Makefile.in
|
|
@@ -34,7 +34,7 @@
|
|
CCOPT = @V_CCOPT@
|
|
DEFS = @DEFS@
|
|
INCLS = -I..
|
|
-CFLAGS = $(CCOPT) $(DEFS) $(INCLS)
|
|
+CFLAGS += $(CCOPT) $(DEFS) $(INCLS)
|
|
LDFLAGS = @LDFLAGS@ @V_STATICFLAG@
|
|
LIBS = @LIBS@
|
|
NETLIBS = @V_NETLIBS@
|
|
@@ -69,15 +69,15 @@
|
|
install: all
|
|
-mkdir -p $(CGIBINDIR)
|
|
rm -f $(CGIBINDIR)/redirect
|
|
- cp redirect $(CGIBINDIR)/redirect
|
|
+ $(BSD_INSTALL_PROGRAM) redirect $(CGIBINDIR)/redirect
|
|
rm -f $(MANDIR)/man8/redirect.8
|
|
- cp redirect.8 $(MANDIR)/man8/redirect.8
|
|
+ $(BSD_INSTALL_MAN) redirect.8 $(MANDIR)/man8/redirect.8
|
|
rm -f $(CGIBINDIR)/ssi
|
|
- cp ssi $(CGIBINDIR)/ssi
|
|
+ $(BSD_INSTALL_PROGRAM) ssi $(CGIBINDIR)/ssi
|
|
rm -f $(MANDIR)/man8/ssi.8
|
|
- cp ssi.8 $(MANDIR)/man8/ssi.8
|
|
+ $(BSD_INSTALL_MAN) ssi.8 $(MANDIR)/man8/ssi.8
|
|
rm -f $(CGIBINDIR)/phf
|
|
- cp phf $(CGIBINDIR)/phf
|
|
+ $(BSD_INSTALL_PROGRAM) phf $(CGIBINDIR)/phf
|
|
|
|
clean:
|
|
rm -f $(CLEANFILES)
|