be443f0c5e
Notable changes in this latest version are listed here. Some code cleanup work and documentation editing has also been done. 256-color limit removed Icon's X-windows interface previously limited each window to 256 colors at one time. This limitation has been removed for the TrueColor displays provided by most modern computers. Median-cut quantization is used to select 256 image colors when WriteImage() is called to write a GIF file. Library changes As usual, several files in the Icon program library have been added or edited. The core library files, however, remain stable. Minor changes * The command "icon - [args]" can now be used to execute a source program read from standard input. * A new "icont -N" flag suppresses embedding of an iconx path in the generated executable * The configuration directory has been restructured. * Several obsolete configurations have been removed. * The environment variables HEAPSIZE and BLOCKSIZE no longer function as undocumented alternatives to BLKSIZE. The GNU ls utility uses BLOCKSIZE for other purposes, leading to confusion. * "make Install" has been changed to never delete anything. It now creates a new directory rather than altering an existing one.
64 lines
1.9 KiB
Text
64 lines
1.9 KiB
Text
$NetBSD: patch-an,v 1.5 2003/06/06 08:58:43 jtb Exp $
|
|
|
|
--- ipl/Makefile.orig
|
|
+++ ipl/Makefile
|
|
@@ -8,9 +8,9 @@
|
|
|
|
Ilib: cfuncs/libcfunc.so
|
|
cfuncs/libcfunc.so: ../bin/icont
|
|
- cp incl/*.icn gincl/*.icn cfuncs/icall.h ../lib
|
|
- cd procs; LPATH= ../../bin/icont -usc *.icn; mv *.u? ../../lib
|
|
- cd gprocs; LPATH= ../../bin/icont -usc *.icn; mv *.u? ../../lib
|
|
+ cp incl/*.icn gincl/*.icn cfuncs/icall.h ../lib/icon
|
|
+ cd procs; LPATH= ../../bin/icont -usc *.icn; mv *.u? ../../lib/icon
|
|
+ cd gprocs; LPATH= ../../bin/icont -usc *.icn; mv *.u? ../../lib/icon
|
|
if grep '^ *# *define LoadFunc' ../src/h/define.h >/dev/null; \
|
|
then $(MAKE) Cfunctions; fi
|
|
|
|
@@ -19,12 +19,12 @@
|
|
|
|
Cfunctions:
|
|
cd cfuncs; LPATH= $(MAKE) ICONT=../../bin/icont
|
|
- cp cfuncs/*.u? ../lib
|
|
- cp cfuncs/libcfunc.so ../bin
|
|
+ cp cfuncs/*.u? ../lib/icon
|
|
+ cp cfuncs/libcfunc.so ../lib/icon
|
|
|
|
|
|
# Make selected graphics program binaries (platform-dependent icode)
|
|
-# for ../bin, given that ../lib is ready
|
|
+# for ../bin, given that ../lib/icon is ready
|
|
|
|
Ibin: gpacks/vib/vib
|
|
gpacks/vib/vib: ../bin/icont
|
|
@@ -32,18 +32,18 @@
|
|
|
|
|
|
# Make a full set of program binaries (not usually done) in ./iexe,
|
|
-# given that ../lib is ready
|
|
+# given that ../lib/icon is ready
|
|
|
|
Iexe:
|
|
rm -f iexe/*
|
|
MAKE=$(MAKE) ./BuildExe
|
|
|
|
|
|
-# Check for undefined identifiers in ../lib.
|
|
+# Check for undefined identifiers in ../lib/icon.
|
|
# (A few are expected: references to Mp, program, init, goal).
|
|
|
|
Undef:
|
|
- cd ../lib; for f in *.u2; do (echo $$f; icont -us -fs $$f); done
|
|
+ cd ../lib/icon; for f in *.u2; do (echo $$f; icont -us -fs $$f); done
|
|
|
|
|
|
# Check for stray files
|
|
@@ -67,7 +67,7 @@
|
|
zip -qrX9 gipl.zip gdocs gincl gprocs gprogs gpacks gdata -x '*/CVS/*'
|
|
zip -qrX9 mipl.zip mincl mprocs mprogs -x '*/CVS/*'
|
|
mkdir ilib
|
|
- cp ../lib/*.* ilib
|
|
+ cp ../lib/icon/*.* ilib
|
|
zip -qrX9 ilib.zip ilib
|
|
rm -rf ilib
|
|
|