pkgsrc/net/libdnet/patches/patch-src_intf.c
obache 9ff286adf9 * remove patch-aa, one patch for multple files, not registerd in distinfo.
split to multiple patches with new style patch file name, and regist.
* set LICENSE=modified-bsd.
* dependency on devel/check is just a build-depend, for test only.
2011-02-07 05:45:17 +00:00

24 lines
604 B
C

$NetBSD: patch-src_intf.c,v 1.1 2011/02/07 05:45:18 obache Exp $
* Add support for SIOCGIFCONF interface
--- src/intf.c.orig 2006-01-09 07:09:49.000000000 +0000
+++ src/intf.c
@@ -55,6 +55,9 @@
# define ifr_mtu ifr_metric
#endif
+#ifdef HAVE_IFREQ_IFR_SPACE
+# define NEXTIFR(i) (i + 1)
+#else
#ifdef HAVE_SOCKADDR_SA_LEN
# define NEXTIFR(i) ((struct ifreq *)((u_char *)&i->ifr_addr + \
(i->ifr_addr.sa_len ? i->ifr_addr.sa_len : \
@@ -62,6 +65,7 @@
#else
# define NEXTIFR(i) (i + 1)
#endif
+#endif
/* XXX - superset of ifreq, for portable SIOC{A,D}IFADDR */
struct dnet_ifaliasreq {