pkgsrc/chat/phone/patches/patch-conv_Makefile

34 lines
1.3 KiB
Text

$NetBSD: patch-conv_Makefile,v 1.2 2014/01/06 22:11:50 joerg Exp $
Configure for pkgsrc.
--- conv/Makefile.orig 2013-01-02 23:00:43.000000000 +0000
+++ conv/Makefile
@@ -5,22 +5,22 @@
# This one is pretty straightforward - no special flags for it.
CC = cc
-CFLAGS+= -std=gnu99 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wno-sign-compare -Wno-traditional -Wa,--fatal-warnings -Wreturn-type -Wswitch -Wshadow -Wcast-qual -Wwrite-strings -Wextra -Wno-unused-parameter -Wno-sign-compare -Wold-style-definition -Wsign-compare -Wformat=2 -Wno-format-zero-length -Werror
+CFLAGS+= -std=gnu99 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wno-sign-compare -Wa,--fatal-warnings -Wreturn-type -Wswitch -Wshadow -Wcast-qual -Wwrite-strings -Wextra -Wno-unused-parameter -Wno-sign-compare -Wold-style-definition -Wsign-compare -Wformat=2 -Wno-format-zero-length -Werror
CFLAGS += -g
SRCS = convd.c
DEST = convd
-RDEST = /usr/etc/convd
+RDEST = ${PREFIX}/libexec/convd
all: ${DEST}
${DEST}: ${SRCS}
- /bin/rm -f ${DEST}
+ rm -f ${DEST}
${CC} ${CFLAGS} -o ${DEST} ${SRCS}
install: ${DEST}
- /bin/rm -f ${RDEST}
- cp ${DEST} ${RDEST}
+ rm -f ${RDEST}
+ ${BSD_INSTALL_PROGRAM} ${DEST} ${DESTDIR}${RDEST}
clean:
/bin/rm -f ${DEST} core *.o