pkgsrc/www/seamonkey/patches/patch-mail_app_Makefile.in
ryoon 6db9ce4826 Update to 2.14
* Patches are synced with xulrunner-17.0, and regen patches
* Update Mozilla Lightning to 1.9

Changelog:
SeaMonkey-specific changes
    None (see changes page for minor changes).

Mozilla platform changes
    OS X 10.6 is now the minimum supported Mac version.
    JavaScript Maps and Sets are now iterable.
    SVG FillPaint and StrokePaint have been implemented.
    The sandbox attribute has been implemented for iframes, enabling increased security.
    Fixed several stability issues.

Security fixes
Fixed in SeaMonkey 2.14
MFSA 2012-106 Use-after-free, buffer overflow, and memory corruption issues found using Address Sanitizer
MFSA 2012-105 Use-after-free and buffer overflow issues found using Address Sanitizer
MFSA 2012-103 Frames can shadow top.location
MFSA 2012-101 Improper character decoding in HZ-GB-2312 charset
MFSA 2012-100 Improper security filtering for cross-origin wrappers
MFSA 2012-99 XrayWrappers exposes chrome-only properties when not in chrome compartment
MFSA 2012-97 XMLHttpRequest inherits incorrect principal within sandbox
MFSA 2012-96 Memory corruption in str_unescape
MFSA 2012-94 Crash when combining SVG text on path with CSS
MFSA 2012-93 evalInSanbox location context incorrectly applied
MFSA 2012-92 Buffer overflow while rendering GIF images
MFSA 2012-91 Miscellaneous memory safety hazards (rv:17.0/ rv:10.0.11)
2012-11-23 17:28:48 +00:00

15 lines
368 B
Text

$NetBSD: patch-mail_app_Makefile.in,v 1.5 2012/11/23 17:28:49 ryoon Exp $
--- mail/app/Makefile.in.orig 2012-11-18 10:14:23.000000000 +0000
+++ mail/app/Makefile.in
@@ -63,6 +63,10 @@ LOCAL_INCLUDES += \
DEFINES += -DXPCOM_GLUE
STL_FLAGS=
+ifeq ($(OS_ARCH),NetBSD)
+LIBS += -lossaudio
+endif
+
LIBS += \
$(EXTRA_DSO_LIBS) \
$(XPCOM_STANDALONE_GLUE_LDOPTS) \