2923403c64
Copy config.h to faad2-config.h. Modify systems.h to refer to faad2-config.h, and install faad2-config.h. This situation is discussed here: http://lists.gnu.org/archive/html/automake/2000-10/msg00114.html Remove the undef of PACKAGE and VERSION, and add a 3rd non-empty argument to AM_INIT_AUTOMAKE. This situation is discussed here: http://lists.gnu.org/archive/html/automake/2000-10/msg00108.html Modify the condition from HAVE_GLIB_H to __G_LIB_H__, which was easier because faad2 doesn't depend on glib. Bump pkgrevision.
25 lines
837 B
Text
25 lines
837 B
Text
$NetBSD: patch-ak,v 1.2 2005/10/09 03:23:11 ben Exp $
|
|
|
|
--- configure.in.orig 2004-02-06 08:04:39.000000000 -0800
|
|
+++ configure.in
|
|
@@ -1,5 +1,5 @@
|
|
AC_INIT
|
|
-AM_INIT_AUTOMAKE(faad2, 2.0)
|
|
+AM_INIT_AUTOMAKE(faad2, 2.0, do-not-define-PACKAGE-or-VERSION)
|
|
|
|
AC_PROG_LIBTOOL
|
|
AC_SUBST(LIBTOOL_DEPS)
|
|
@@ -114,7 +114,7 @@ if test x$WITHDRM = xyes; then
|
|
AC_DEFINE(DRM, 1, [Define if you want to use libfaad together with Digital Radio Mondiale (DRM)])
|
|
fi
|
|
|
|
-AC_CONFIG_FILES(libfaad/Makefile frontend/Makefile common/Makefile plugins/Makefile Makefile )
|
|
+AC_CONFIG_FILES(libfaad/Makefile frontend/Makefile common/Makefile plugins/Makefile include/Makefile Makefile )
|
|
|
|
AC_CONFIG_FILES(plugins/mpeg4ip/Makefile)
|
|
|
|
@@ -122,3 +122,4 @@ AC_CONFIG_FILES(common/mp4ff/Makefile co
|
|
|
|
AC_CONFIG_FILES(faad2.spec)
|
|
AC_OUTPUT
|
|
+cp config.h faad2-config.h
|