pkgsrc/net/pload/patches/patch-ac
dholland 7e11d597e6 Teach the configure script to recognize a bunch more OSes, and remove
NOT_FOR_PLATFORM restriction. There's a good chance the thing won't
build on these OSes, but if so we can always reinsert the restrictions
as BROKEN_ON_PLATFORM.
2015-01-04 03:57:30 +00:00

50 lines
1 KiB
Text

$NetBSD: patch-ac,v 1.3 2015/01/04 03:57:30 dholland Exp $
- recognize dragonfly, openbsd, macos, hpux
- use pkgsrc imake
--- configure.orig 2000-02-01 07:11:24.000000000 +0000
+++ configure
@@ -17,12 +17,21 @@ case $system in
echo "enabling proc stats reading";
fi
;;
+ DragonFly)
+ os="dragonfly";
+ ;;
FreeBSD)
os="freebsd";
;;
NetBSD)
os="netbsd";
;;
+ OpenBSD)
+ os="openbsd";
+ ;;
+ Darwin)
+ os="macos";
+ ;;
SunOS)
os="sunos";
streams="-DSTREAMS";
@@ -36,6 +45,11 @@ case $system in
streams="-DSTREAMS";
sys_src="strioctl.c"
;;
+ HP-UX)
+ os="hpux";
+ streams="-DSTREAMS";
+ sys_src="strioctl.c"
+ ;;
UNIX*)
os="svr4";
streams="-DSTREAMS";
@@ -62,7 +76,7 @@ else
# is this proper sed syntax?
echo "OBJS=`echo $common_src $sys_src | sed s/'\.c'/'\.o'/g`" >> osdefs.mk
- xmkmf && make depend && \
+ (pkgxmkmf || xmkmf) && make depend && \
echo "configured for $os" && \
echo "type \"make\" to build" && \
echo "type \"make install ; make install.man\" to install"