pkgsrc/devel/libblkid/patches/patch-af
markd a22548c643 Initial import libblkid 2.18
The libblkid library is used to identify block devices (disks) as to their
content (e.g. filesystem type) as well as extracting additional information
such as filesystem labels/volume names, unique identifiers/serial numbers, etc.
A common use is to allow use of LABEL= and UUID= tags instead of hard-coding
specific block device names into configuration files.

From util-linux-ng.
2011-01-08 20:43:38 +00:00

19 lines
788 B
Text

$NetBSD: patch-af,v 1.1.1.1 2011/01/08 20:43:39 markd Exp $
Dont add installed libuuid to dependecies but link it in
--- shlibs/blkid/src/Makefile.in.orig 2010-06-30 12:53:06.000000000 +0000
+++ shlibs/blkid/src/Makefile.in
@@ -382,7 +382,11 @@ libblkid_la_LIBADD = superblocks/libblki
partitions/libblkid_partitions.la \
$(common_ldadd)
-libblkid_la_DEPENDENCIES = $(libblkid_la_LIBADD) blkid.sym blkid.h.in
+libblkid_la_LIBADDx = superblocks/libblkid_superblocks.la \
+ topology/libblkid_topology.la \
+ partitions/libblkid_partitions.la
+
+libblkid_la_DEPENDENCIES = $(libblkid_la_LIBADDx) blkid.sym blkid.h.in
libblkid_la_LDFLAGS = -Wl,--version-script=$(ul_libblkid_srcdir)/blkid.sym \
-version-info $(LIBBLKID_VERSION_INFO)