pkgsrc/devel/libcfg+/patches/patch-ab

76 lines
2.5 KiB
Text
Raw Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

$NetBSD: patch-ab,v 1.1 2004/10/06 10:17:06 grant Exp $
--- src/Makefile.in.orig 2004-02-18 01:37:47.000000000 +0900
+++ src/Makefile.in 2004-09-29 00:32:45.000000000 +0900
@@ -60,16 +60,16 @@
$(srcdir)/platon/str/strdyn.c \
$(srcdir)/platon/str/dynfgets.c
-OBJECTS = $(top_builddir)/src/cfg+.o \
- $(top_builddir)/src/parse.o \
- $(top_builddir)/src/props.o \
- $(top_builddir)/src/cmdline.o \
- $(top_builddir)/src/cfgfile.o \
- $(top_builddir)/src/shared.o \
- $(top_builddir)/src/platon/str/strplus.o \
- $(top_builddir)/src/platon/str/strctype.o \
- $(top_builddir)/src/platon/str/strdyn.o \
- $(top_builddir)/src/platon/str/dynfgets.o
+OBJECTS = $(top_builddir)/src/cfg+.lo \
+ $(top_builddir)/src/parse.lo \
+ $(top_builddir)/src/props.lo \
+ $(top_builddir)/src/cmdline.lo \
+ $(top_builddir)/src/cfgfile.lo \
+ $(top_builddir)/src/shared.lo \
+ $(top_builddir)/src/platon/str/strplus.lo \
+ $(top_builddir)/src/platon/str/strctype.lo \
+ $(top_builddir)/src/platon/str/strdyn.lo \
+ $(top_builddir)/src/platon/str/dynfgets.lo
# SunOS 4 make does not allow multiple makefiles to be specified in one ­include directive.
DEP_FILES = $(top_builddir)/src/.deps/cfg+.P \
@@ -97,8 +97,7 @@
platon/str/strplus.h
LIBSTATIC = $(PACKAGE).a
-LIBDYNAMIC = $(PACKAGE).so
-LIBDYNAMICV = $(PACKAGE).so.$(VERSION)
+LIBDYNAMICV = $(PACKAGE).la
install_LIB = $(LIBSTATIC) $(LIBDYNAMICV)
@@ -166,7 +165,7 @@
@list='$(install_LIB)'; for p in $$list; do \
if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
echo " Installing file $(DESTDIR)$(libdir)/$$p"; \
- $(INSTALL_DATA) $$d$$p $(DESTDIR)$(libdir)/$$p; \
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) $$d$$p $(DESTDIR)$(libdir)/$$p; \
done
uninstall-lib:
@$(NORMAL_UNINSTALL)
@@ -217,11 +216,7 @@
cd platon && $(LN_S) $$p $(include_SYMLINK); \
); \
cd $$here; \
- done; \
- cd $(DESTDIR)$(libdir) && ( \
- echo " Creating symlink $(DESTDIR)$(libdir)/$(LIBDYNAMIC)"; \
- $(LN_S) $(LIBDYNAMICV) $(LIBDYNAMIC); \
- );
+ done;
uninstall-symlinks:
@$(NORMAL_UNINSTALL)
-@list='$(include_SYMLINK)'; for p in $$list; do \
@@ -229,11 +224,7 @@
rm -f $(DESTDIR)$(includedir)/$$p; \
echo " rm -f $(DESTDIR)$(includedir_platon)/$$p"; \
rm -f $(DESTDIR)$(includedir_platon)/$$p; \
- done; \
- cd $(DESTDIR)$(libdir) && ( \
- echo " rm -f $(DESTDIR)$(libdir)/$(LIBDYNAMIC)"; \
- rm -f $(LIBDYNAMIC); \
- );
+ done;
uninstall-dirs:
@$(NORMAL_UNINSTALL)