pkgsrc/devel/gdb/patches/patch-gdb_gdbserver_Makefile.in
sbd d3c6d8b7f7 If <stdlib.h> is needed and its wrapped with HAVE_STDDLIB_H it must be
tested for by autoconf!

<stdlib.h> is needed as it include <alloca.h> which is needed for alloca(3).

Also fix DESTDIR support for gdbserver.
2011-12-05 22:15:05 +00:00

15 lines
661 B
Text

$NetBSD: patch-gdb_gdbserver_Makefile.in,v 1.1 2011/12/05 22:15:05 sbd Exp $
--- gdb/gdbserver/Makefile.in.orig 2002-08-20 21:32:18.000000000 +0000
+++ gdb/gdbserver/Makefile.in
@@ -145,8 +145,8 @@ install: all install-only
install-only:
n=`echo gdbserver | sed '$(program_transform_name)'`; \
if [ x$$n = x ]; then n=gdbserver; else true; fi; \
- $(INSTALL_PROGRAM) gdbserver $(bindir)/$$n; \
- $(INSTALL_DATA) $(srcdir)/gdbserver.1 $(man1dir)/$$n.1
+ $(INSTALL_PROGRAM) gdbserver $(DESTDIR)$(bindir)/$$n; \
+ $(INSTALL_DATA) $(srcdir)/gdbserver.1 $(DESTDIR)$(man1dir)/$$n.1
uninstall: force
n=`echo gdbserver | sed '$(program_transform_name)'`; \