pkgsrc/www/seamonkey/patches/patch-mozilla_netwerk_dns_Makefile.in
ryoon 8976ac158b Update to 2.26.1
Changelog:
SeaMonkey-specific changes

    The delimiter for forwarded messages can now be configured.
    An option to not strip signatures on reply has been added to prevent top signatures from deleting the body.
    Add to Searchbar (search-engine autodiscovery) was implemented.
    The location bar tooltip now shows the complete current URL in case it is displayed only partially.
    See the changes page for a more complete overview.

Mozilla platform changes

    The Gamepad API has been finalized and enabled (learn more).
    navigator.plugins is no longer enumerable, for user privacy.
    ECMAScript Internationalization API has been enabled.
    'box-sizing' (dropping the -moz- prefix) has been implemented.
    SharedWorker is now enabled by default.
    CSS3 variables have been implemented.
    Console object is now available in Web Workers.
    Promises have been enabled by default.
    <input type="number"> has been implemented and enabled.
    <input type="color"> has been implemented and enabled.
    Fixed several stability issues.

Fixed in SeaMonkey 2.26.1
MFSA 2014-54 Buffer overflow in Gamepad API
MFSA 2014-53 Buffer overflow in Web Audio Speex resampler
MFSA 2014-52 Use-after-free with SMIL Animation Controller
MFSA 2014-51 Use-after-free in Event Listener Manager
MFSA 2014-49 Use-after-free and out of bounds issues found using Address Sanitizer
MFSA 2014-48 Miscellaneous memory safety hazards (rv:30.0 / rv:24.6)
Fixed in SeaMonkey 2.26
MFSA 2014-47 Debugger can bypass XrayWrappers with JavaScript
MFSA 2014-46 Use-after-free in nsHostResolve
MFSA 2014-45 Incorrect IDNA domain name matching for wildcard certificates
MFSA 2014-44 Use-after-free in imgLoader while resizing images
MFSA 2014-43 Cross-site scripting (XSS) using history navigations
MFSA 2014-42 Privilege escalation through Web Notification API
MFSA 2014-41 Out-of-bounds write in Cairo
MFSA 2014-39 Use-after-free in the Text Track Manager for HTML video
MFSA 2014-38 Buffer overflow when using non-XBL object as XBL
MFSA 2014-37 Out of bounds read while decoding JPG images
MFSA 2014-36 Web Audio memory corruption issues
MFSA 2014-34 Miscellaneous memory safety hazards (rv:29.0 / rv:24.5)
2014-06-22 08:54:39 +00:00

15 lines
501 B
Text

$NetBSD: patch-mozilla_netwerk_dns_Makefile.in,v 1.2 2014/06/22 08:54:39 ryoon Exp $
--- mozilla/netwerk/dns/Makefile.in.orig 2014-06-13 00:45:47.000000000 +0000
+++ mozilla/netwerk/dns/Makefile.in
@@ -5,6 +5,10 @@
include $(topsrcdir)/config/rules.mk
+ifdef MOZ_NATIVE_HARFBUZZ
+CXXFLAGS += $(MOZ_HARFBUZZ_CFLAGS)
+endif
+
# Generate the include file containing compact, static definitions
# for effective TLD data.
etld_data.inc: $(srcdir)/prepare_tlds.py $(srcdir)/effective_tld_names.dat