03de084caa
- Integrated Garmin Simple Text Protocol driver from Peter Slansky. Minor fixes in error modeling and a better NaN guard stabilize the Trimble regression tests. Remove the wired-in NTP time offset from the NMEA driver, this could only have worked by accident and should be set in ntpd.conf. Integrated Ashtech driver from Chris Kuethe. - Navcom driver merged. Removed -d -f and -p options of gpsd; these have been undocumented for a while. Make gpsd play well with pkgconfig. Incorrect computation of VDOP when GPSes didn't supply it has been fixed. The xgps code has been revamped and now has a much nicer interface. Add -b (no-configuration) option as a sadly clumsy workaround for some problems with Bluetooth receivers. Added tests for Haicom-305N and Pharos 360; separated out the tests for the unstable Trimble drivers. 32-vs-64-bit problems in the regression tests have been solved. - Fix for byte-swapping of Zodiac control messages on big-endian hardware. Disable iTalk by default and note that it needs to be tested. Command line arguments can now be DGPSIP or NTRIP URLs; -d is deprecated. Added udev rules. Address excessive processor and memory utilization on SBCs; it's now possible to configure compile-time limits on the number of devices and client sessions. Eliminate use of fuser(1) in gpsfake. Get gpsd working with EarthMates again, this had been broken since 2.15. Massive string safety audit and OpenBSD port by Chris Kuethe. J command added. The gpsctl and gpscat tools and the gpsd.phps script were added. Switched to lesstif from openmotif. Better autodetection of DLE-led packet protocols (notably TSIP and Garmin binary) and of SiRFStar I and III devices. Fixed buggy parsing and generation of PGRME.
34 lines
1.3 KiB
Text
34 lines
1.3 KiB
Text
$NetBSD: patch-aa,v 1.5 2008/01/15 00:58:17 gdt Exp $
|
|
|
|
Not 100% sure about this, but it is not apparently fixed upstream.
|
|
I think we should have a configure.ac patch as well for regeneration.)
|
|
|
|
|
|
--- configure.orig 2008-01-01 13:44:00.000000000 -0500
|
|
+++ configure
|
|
@@ -25345,13 +25345,13 @@ if test $ac_cv_lib_c_open = yes; then
|
|
fi
|
|
|
|
|
|
-{ echo "$as_me:$LINENO: checking for pthread_setcancelstate in -lpthread" >&5
|
|
-echo $ECHO_N "checking for pthread_setcancelstate in -lpthread... $ECHO_C" >&6; }
|
|
+{ echo "$as_me:$LINENO: checking for pthread_setcancelstate in ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}" >&5
|
|
+echo $ECHO_N "checking for pthread_setcancelstate in ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}... $ECHO_C" >&6; }
|
|
if test "${ac_cv_lib_pthread_pthread_setcancelstate+set}" = set; then
|
|
echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
else
|
|
ac_check_lib_save_LIBS=$LIBS
|
|
-LIBS="-lpthread $LIBS"
|
|
+LIBS="${PTHREAD_LDFLAGS} ${PTHREAD_LIBS} $LIBS"
|
|
cat >conftest.$ac_ext <<_ACEOF
|
|
/* confdefs.h. */
|
|
_ACEOF
|
|
@@ -25407,7 +25407,7 @@ fi
|
|
{ echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_setcancelstate" >&5
|
|
echo "${ECHO_T}$ac_cv_lib_pthread_pthread_setcancelstate" >&6; }
|
|
if test $ac_cv_lib_pthread_pthread_setcancelstate = yes; then
|
|
- LIBPTHREAD="-lpthread"
|
|
+ LIBPTHREAD="${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}"
|
|
|
|
cat >>confdefs.h <<\_ACEOF
|
|
#define HAVE_LIBPTHREAD
|