pkgsrc/lang/pc-lisp/patches/patch-src_Makefile
kamil 7af7f94243 lang/pc-lisp: import pc-lisp-6.0
PC-LISP is a small implementation of LISP for just about any machine with a
good C compiler. This manual is biased towards the UNIX and MS-DOS versions.

While small, it is capable of running a pretty good subset of Franz LISP.
The functions are supposed to perform in the same way as Franz with a few
exceptions made for effeciencies sake.
2018-02-03 20:26:31 +00:00

21 lines
528 B
Text

$NetBSD: patch-src_Makefile,v 1.1 2018/02/03 20:26:31 kamil Exp $
Pass CFLAGS and LDFLAGS.
--- src/Makefile.orig 2015-07-22 00:49:58.000000000 +0000
+++ src/Makefile
@@ -31,12 +31,12 @@ buuntrac.c buwhile.c buzaplin.c buzerop.
lierror.c lieval.c liinst.c limain.c limkstak.c limman.c liscan.c \
lithrow.c litrace.c liutils.c
-CFLAGS = -Wall -Wno-parentheses -O3
+CFLAGS ?= -Wall -Wno-parentheses -O3
OBJ = $(SRC:.c=.o)
pc-lisp : $(OBJ)
- gcc -o $@ $^ -lm
+ gcc $(CFLAGS) $(LDFLAGS) -o $@ $^ -lm
$(OBJ) : lisp.h