16 lines
757 B
Text
16 lines
757 B
Text
$NetBSD: patch-CMakeLists.txt,v 1.5 2012/06/01 21:24:57 wiz Exp $
|
|
|
|
Handle DragonFly like NetBSD and FreeBSD.
|
|
http://code.opencv.org/issues/2010
|
|
|
|
--- CMakeLists.txt.orig 2012-05-31 14:06:56.000000000 +0000
|
|
+++ CMakeLists.txt
|
|
@@ -318,7 +318,7 @@ if(UNIX)
|
|
CHECK_INCLUDE_FILE(pthread.h HAVE_LIBPTHREAD)
|
|
if(ANDROID)
|
|
set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} dl m log)
|
|
- elseif(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "NetBSD")
|
|
+ elseif(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "NetBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
|
|
set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} m pthread)
|
|
else()
|
|
set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} dl m pthread rt)
|