pkgsrc/textproc/FlightCrew/patches/patch-CMakeLists.txt
ryoon 1f7e78bc66 Import FlightCrew-0.7.1 as textproc/FlightCrew from wip/FlightCrew
FlightCrew is a C++, cross-platform, native code epub validator.
It is composed of three parts:

* FlightCrew, the validation library;
* FlightCrew-cli, the command-line front-end to the FlightCrew library;
* FlightCrew-gui, the GUI front-end to the FlightCrew library;
2011-07-29 19:32:18 +00:00

23 lines
772 B
Text

$NetBSD: patch-CMakeLists.txt,v 1.1.1.1 2011/07/29 19:32:18 ryoon Exp $
* Use external boost, xerces-c, zlib, and gmock.
--- CMakeLists.txt.orig 2010-11-11 10:05:50.000000000 +0000
+++ CMakeLists.txt
@@ -42,12 +42,12 @@ set( CMAKE_OSX_SYSROOT "/Developer/SDKs/
set( CMAKE_OSX_ARCHITECTURES "i386;x86_64" )
# The parsing order is significant!
-add_subdirectory( src/BoostParts )
-add_subdirectory( src/Xerces )
+#add_subdirectory( src/BoostParts )
+#add_subdirectory( src/Xerces )
add_subdirectory( src/XercesExtensions )
-add_subdirectory( src/zlib )
+#add_subdirectory( src/zlib )
add_subdirectory( src/zipios )
-add_subdirectory( src/googlemock )
+#add_subdirectory( src/googlemock )
add_subdirectory( src/FlightCrew )
add_subdirectory( src/FlightCrew-cli )