Pointed out in PR 35383. Jan 05 2007, V3.52.5: * Added support for FileDSN * Added support for Connection Pooling * Added check for tracefile size * Call ODBC 2.x functions in driver if application uses ODBC 2.x only calls * Fixed problem parsing driver result in SQLSetStmtAttr * Fixed source code readability * Fixed bug in overwriting driver name * Fixed check for /Library/ODBC for Mac OS X * Fixed prototypes * Rewrote bootstrap script and configure summary * Use localtime_r in tracing when available * Fixed build issues with Mac OS X * Small code cleanups and fixes Jan 26 2006, V3.52.4: * Added support for Mac OS X 10.4 Universal kit (ppc, ppc64 and i386) * Removed dependency between iodbc and iodbcinst shared libraries * Cleanup Mac OS X build process * Clarify LGPL license conditions * Fixed problem with error on subsequent SQLExecute statements * Fixed problem building 64bit GUI components * Fixed compiler warnings * Fixed problem determining which compiler to use on AIX * Enabled SHLIB_PATH on HP/UX * Fixed problem using # as comment in odbc.ini file * Disabled --disable-odbc3 flag * Small code cleanups and fixes pkgsrc chages: Fix comment and descr, refrect current status.
17 lines
860 B
Text
17 lines
860 B
Text
$NetBSD: patch-ac,v 1.2 2007/01/12 17:27:20 obache Exp $
|
|
|
|
--- samples/Makefile.in.orig 2007-01-05 12:54:29.000000000 +0000
|
|
+++ samples/Makefile.in
|
|
@@ -572,9 +572,9 @@ uninstall-am: uninstall-binPROGRAMS unin
|
|
|
|
|
|
install-exec-hook:
|
|
- $(mkinstalldirs) ${DESTDIR}${pkgdatadir}/samples
|
|
- cp $(srcdir)/iodbctest.c ${DESTDIR}${pkgdatadir}/samples/iodbctest.c
|
|
- cp $(srcdir)/Makefile.sample ${DESTDIR}${pkgdatadir}/samples/Makefile
|
|
+ $(mkinstalldirs) ${DESTDIR}${datadir}/examples/iodbc
|
|
+ cp $(srcdir)/iodbctest.c ${DESTDIR}${datadir}/examples/iodbc/iodbctest.c
|
|
+ cp $(srcdir)/Makefile.sample ${DESTDIR}${datadir}/examples/iodbc/Makefile
|
|
@DARWIN_TRUE@ -/usr/bin/lipo ${DESTDIR}${bindir}/iodbctest -remove ppc64 -output ${DESTDIR}${bindir}/iodbctest
|
|
@DARWIN_TRUE@ -/usr/bin/lipo ${DESTDIR}${bindir}/iodbctestw -remove ppc64 -output ${DESTDIR}${bindir}/iodbctestw
|
|
|