pkgsrc/security/heimdal/patches/patch-al
adam 169afc7d7b Changes 1.4:
New features
* Support for reading MIT database file directly
* KCM is polished up and now used in production
* NTLM first class citizen, credentials stored in KCM
* Table driven ASN.1 compiler, smaller!, not enabled by default
* Native Windows client support
Notes
* Disabled write support NDBM hdb backend (read still in there) since
  it can't handle large records, please migrate to a diffrent backend
  (like BDB4)

Changes 1.3.3:
Bug fixes
* Check the GSS-API checksum exists before trying to use it [CVE-2010-1321]
* Check NULL pointers before dereference them [kdc]

Changes 1.3.2:
Bug fixes
* Don't mix length when clearing hmac (could memset too much)
* More paranoid underrun checking when decrypting packets
* Check the password change requests and refuse to answer empty packets
* Build on OpenSolaris
* Renumber AD-SIGNED-TICKET since it was stolen from US
* Don't cache /dev/*random file descriptor, it doesn't get unloaded
* Make C++ safe
* Misc warnings
2011-07-08 09:49:21 +00:00

13 lines
516 B
Text

$NetBSD: patch-al,v 1.3 2011/07/08 09:49:22 adam Exp $
--- lib/roken/Makefile.in.orig 2010-09-13 07:24:23.000000000 +0000
+++ lib/roken/Makefile.in
@@ -1990,6 +1990,8 @@ $(LTLIBOBJS) $(libroken_la_OBJECTS): rok
@CROSS_COMPILE_TRUE@ -c $(top_builddir)/include/config.h \
@CROSS_COMPILE_TRUE@ -p $(srcdir)/roken.h.in -o roken.h
+print-xheaders:
+ @echo $(XHEADERS)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: