pkgsrc/net/rabbitmq/patches/patch-deps_rabbitmq__cli_Makefile
fhajny 7cd86ffd62 Update net/rabbitmq to 3.7.3.
- Bug fixes
- Usability improvements

Full release notes:

  https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.7.3
2018-02-02 16:20:21 +00:00

18 lines
615 B
Text

$NetBSD: patch-deps_rabbitmq__cli_Makefile,v 1.1 2018/02/02 16:20:21 fhajny Exp $
Somehow there is a pre-existing file.
--- deps/rabbitmq_cli/Makefile.orig 2018-01-30 10:33:01.000000000 +0000
+++ deps/rabbitmq_cli/Makefile
@@ -61,9 +61,9 @@ escript/rabbitmq-plugins escript/rabbitm
# the source was previously copied in that directory.
ifdef USE_SYMLINKS_IN_ESCRIPTS_DIR
-link_escript = ln -s "$(notdir $(1))" "$(2)"
+link_escript = ln -sf "$(notdir $(1))" "$(2)"
else
-link_escript = ln "$(dir $(2))$(notdir $(1))" "$(2)"
+link_escript = ln -f "$(dir $(2))$(notdir $(1))" "$(2)"
endif
app:: $(ESCRIPTS)