I just pushed the Speex 1.2.0 stable release. Thanks to Ralph Giles for helping with the release process.
29 lines
844 B
Text
29 lines
844 B
Text
$NetBSD: patch-ab,v 1.8 2016/12/12 14:53:14 wiz Exp $
|
|
|
|
Add getopt/ossaudio libraries where needed.
|
|
|
|
--- src/Makefile.in.orig 2016-12-07 23:21:03.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -260,7 +260,7 @@ LD = @LD@
|
|
LDFLAGS = @LDFLAGS@
|
|
LIBM = @LIBM@
|
|
LIBOBJS = @LIBOBJS@
|
|
-LIBS = @LIBS@
|
|
+LIBS = @LIBS@ ${LIBGETOPT}
|
|
LIBTOOL = @LIBTOOL@
|
|
LIPO = @LIPO@
|
|
LN_S = @LN_S@
|
|
@@ -366,11 +366,11 @@ include_HEADERS =
|
|
noinst_HEADERS = wav_io.h
|
|
speexenc_SOURCES = speexenc.c wav_io.c skeleton.c
|
|
speexenc_LDADD = $(top_builddir)/libspeex/libspeex.la \
|
|
- $(OGG_LIBS) @FFT_LIBS@ @SPEEXDSP_LIBS@
|
|
+ $(OGG_LIBS) @FFT_LIBS@ @SPEEXDSP_LIBS@ $(LIBOSSAUDIO)
|
|
|
|
speexdec_SOURCES = speexdec.c wav_io.c
|
|
speexdec_LDADD = $(top_builddir)/libspeex/libspeex.la \
|
|
- $(OGG_LIBS) @WINMM_LIBS@ @FFT_LIBS@
|
|
+ $(OGG_LIBS) @WINMM_LIBS@ @FFT_LIBS@ $(LIBOSSAUDIO)
|
|
|
|
all: all-am
|
|
|