changes: -API additions -hdp and hrepack utilities can now display more compression information -build system updates -bugfixes pkgsrc notes: -we build shared libraries now although it is officially unsupported if Fortran is enabled (works for me) -The 24-bit-jpeg selftest fails. It also failed with the previous version. (perhaps jpeg-7 related?) The test contains too much magic to tell what happens.
48 lines
2 KiB
Text
48 lines
2 KiB
Text
$NetBSD: patch-ai,v 1.8 2009/12/10 17:10:14 drochner Exp $
|
|
|
|
--- mfhdf/ncdump/Makefile.in.orig 2008-10-13 21:39:11.000000000 +0200
|
|
+++ mfhdf/ncdump/Makefile.in
|
|
@@ -37,7 +37,7 @@ build_triplet = @build@
|
|
host_triplet = @host@
|
|
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
|
|
$(top_srcdir)/config/commence.am
|
|
-bin_PROGRAMS = ncdump$(EXEEXT)
|
|
+bin_PROGRAMS = hdfncdump$(EXEEXT)
|
|
subdir = mfhdf/ncdump
|
|
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
am__aclocal_m4_deps = $(top_srcdir)/configure.ac
|
|
@@ -216,7 +216,7 @@ INCLUDES = -I$(top_srcdir)/hdf/src
|
|
|
|
DEFINES = -DNDEBUG -DHDF
|
|
AM_CPPFLAGS = $(INCLUDES) $(DEFINES)
|
|
-man1_MANS = ncdump.1
|
|
+man1_MANS = hdfncdump.1
|
|
ncdump_SOURCES = dumplib.c ncdump.c vardata.c
|
|
ncdump_LDADD = ../libsrc/libmfhdf.la $(top_builddir)/hdf/src/libdf.la
|
|
ncdump_DEPENDENCIES = $(top_builddir)/hdf/src/libdf.la ../libsrc/libmfhdf.la
|
|
@@ -285,7 +285,7 @@ clean-binPROGRAMS:
|
|
echo " rm -f $$p $$f"; \
|
|
rm -f $$p $$f ; \
|
|
done
|
|
-ncdump$(EXEEXT): $(ncdump_OBJECTS) $(ncdump_DEPENDENCIES)
|
|
+hdfncdump$(EXEEXT): $(ncdump_OBJECTS) $(ncdump_DEPENDENCIES)
|
|
@rm -f ncdump$(EXEEXT)
|
|
$(LINK) $(ncdump_OBJECTS) $(ncdump_LDADD) $(LIBS)
|
|
|
|
@@ -554,11 +554,11 @@ uninstall-man: uninstall-man1
|
|
uninstall-man1
|
|
|
|
|
|
-check: ncdump $(srcdir)/test0.cdl
|
|
- $(TESTS_ENVIRONMENT) ../ncgen/ncgen -o test0.nc -n $(srcdir)/test0.cdl
|
|
- $(TESTS_ENVIRONMENT) ./ncdump test0.nc > test1.cdl
|
|
- $(TESTS_ENVIRONMENT) ../ncgen/ncgen -o test1.nc -n test1.cdl
|
|
- $(TESTS_ENVIRONMENT) ./ncdump -n test0 test1.nc > test2.cdl
|
|
+check: hdfncdump $(srcdir)/test0.cdl
|
|
+ $(TESTS_ENVIRONMENT) ../ncgen/hdfncgen -o test0.nc -n $(srcdir)/test0.cdl
|
|
+ $(TESTS_ENVIRONMENT) ./hdfncdump test0.nc > test1.cdl
|
|
+ $(TESTS_ENVIRONMENT) ../ncgen/hdfncgen -o test1.nc -n test1.cdl
|
|
+ $(TESTS_ENVIRONMENT) ./hdfncdump -n test0 test1.nc > test2.cdl
|
|
@cmp test1.cdl test2.cdl && echo "*** ncdump test successful ***" ; \
|
|
rm -f test1.nc test1.cdl test2.cdl
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|