65fe8e9b94
- split patches files - always enable threading which has various advantages - it fixes the build of the Tk library - it greatly simplifies the package list handling - it provides threading support under NetBSD 1.6/1.6.x - correct default dependence in "buildlink2.mk" to "build" Bump package revision because of all these changes.
17 lines
614 B
Text
17 lines
614 B
Text
$NetBSD: patch-bl,v 1.1 2004/04/22 09:18:44 tron Exp $
|
|
|
|
--- otherlibs/labltk/tkanim/tkAnimGIF.c.orig Tue Jul 23 16:12:00 2002
|
|
+++ otherlibs/labltk/tkanim/tkAnimGIF.c Thu Apr 22 10:34:38 2004
|
|
@@ -336,7 +336,11 @@
|
|
}
|
|
}
|
|
Tk_PhotoPutBlock(photoHandle, &block, 0, 0,
|
|
- imageWidth, imageHeight);
|
|
+ imageWidth, imageHeight
|
|
+#if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 4 || TK_MAJOR_VERSION > 8)
|
|
+ , TK_PHOTO_COMPOSITE_SET
|
|
+#endif
|
|
+ );
|
|
#ifdef TKANIM_DEBUG
|
|
fprintf(stderr, " Retrieving result\n");
|
|
#endif
|