c7d3ffc942
Security fix seems to related to www/ap2-subversion. Version 1.6.16 (02 Mar 2011, from /branches/1.6.x) http://svn.apache.org/repos/asf/subversion/tags/1.6.16 User-visible changes: * more improvement to the 'blame -g' memory leak from 1.6.15 (r1041438) * avoid a crash in mod_dav_svn when using locks (r1071239, -307) See CVE-2011-0715, and descriptive advisory at http://subversion.apache.org/security/CVE-2011-0715-advisory.txt * avoid unnecessary globbing for performance (r1068988) * don't add tree conflicts when one already exists (issue #3486) * fix potential crash when requesting mergeinfo (r902467) * don't attempt to resolve prop conflicts in 'merge --dry-run' (r880146) * more fixes for issue #3270. Developer-visible changes: * ensure report_info_t is properly initialized by ra_serf (r1058722) * locate errors properly on a malfunction (r1053208) * fix output param timing of svn_fs_commit_txn() on fsfs (r1051751) * for svn_fs_commit_txn(), set invalid rev on failed commit (r1051632, -8) * fix sporadic Ruby bindings test failures (r1038792) * fix JavaHL JVM object leak when dumping large revisions (r947006) * use Perl to resolve symlinks when building swig-pl (r1039040) * allow Perl bindings to build within a symlinked working copy (r1036534) * don't overwrite the LD_LIBRARY_PATH during make check-swig-pl (r946355) * improve unit tests for some fs functions (r1051744, -5, -3185, -241)
13 lines
593 B
Text
13 lines
593 B
Text
$NetBSD: patch-ad,v 1.15 2011/03/04 03:12:36 taca Exp $
|
|
|
|
--- Makefile.in.orig 2010-11-25 17:55:59.000000000 +0000
|
|
+++ Makefile.in
|
|
@@ -682,7 +682,7 @@ $(SWIG_PL_DIR)/native/Makefile.PL: $(SWI
|
|
./config.status subversion/bindings/swig/perl/native/Makefile.PL
|
|
|
|
$(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
|
|
- cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL
|
|
+ cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL INSTALLDIRS=vendor
|
|
|
|
# There is a "readlink -f" command on some systems for the same purpose,
|
|
# but it's not as portable (e.g. Mac OS X doesn't have it). These should
|