pkgsrc/www/ap2-xslt2/patches/patch-ad
xtraeme aca495c729 Initial import of ap2-xslt2 (known as mod-xslt2).
mod-xslt2 is a server side module able to transform ``xml''
documents in ``html'' (or to any other format) before they
even get back to the browser.

mod-xslt2 main features include:

* Ability to parse generated xml (ability to parse the output of
  php or perl scripts).

* Ability to use the ``xslt'' indicated by the <?xml-stylesheet
  processing instruction.

* Ability to send back the xml file unparsed to the browser.

* Ability to fetch xslt or DTDs from scripts rather than from
  static files.

* Ability to fetch a different xslt depending on the content of
  the request headers, of the get parameters or the web server
  environment.

* Ability to allow xslt stylesheets to make use of these
  variables to generate output.

--
http://www.mod-xslt2.com/
2006-12-07 02:34:01 +00:00

23 lines
974 B
Text

$NetBSD: patch-ad,v 1.1.1.1 2006/12/07 02:34:01 xtraeme Exp $
--- utils/Makefile.in.orig 2006-12-07 03:03:58.000000000 +0100
+++ utils/Makefile.in 2006-12-07 03:05:11.000000000 +0100
@@ -126,15 +126,15 @@
install: install-modxslt-parse install-modxslt-config install-modxslt-perror
install-modxslt-perror:
- $(LIBTOOL) --mode=install install $(IFLAGS) -D -m 0755 -o root -g root modxslt-perror \
+ $(LIBTOOL) --mode=install $(BSD_INSTALL_PROGRAM) modxslt-perror \
$(DESTDIR)$(bindir)/modxslt-perror
install-modxslt-parse:
- $(LIBTOOL) --mode=install install $(IFLAGS) -D -m 0755 -o root -g root modxslt-parse \
+ $(LIBTOOL) --mode=install $(BSD_INSTALL_PROGRAM) modxslt-parse \
$(DESTDIR)$(bindir)/modxslt-parse
install-modxslt-config:
- install -D -m 0755 -o root -g root modxslt-config \
+ $(BSD_INSTALL_SCRIPT) modxslt-config \
$(DESTDIR)$(bindir)/modxslt-config
uninstall: uninstall-modxslt-parse uninstall-modxslt-config uninstall-modxslt-perror