pkgsrc/security/cyrus-sasl2/patches/patch-aj
seb 3869278076 Update to version 2.1.12.
New in 2.1.12
-------------
* Distribute in Solaris tar (not GNU tar format)
* Fix a number of build/configure related issues.

New in 2.1.11
-------------
* Add the fastbind auth method to the saslauthd LDAP module.
* Fix a potential memory leak in the doors version of saslauthd.
* NTLM now only requires one of LM or NT, not both.
* Fix a variety of Berkeley DB, LDAP, OpenSSL, and other build issues.
* Win32 support compiles, but no documentation as of yet.
2003-02-27 13:18:06 +00:00

76 lines
2.9 KiB
Text

$NetBSD: patch-aj,v 1.3 2003/02/27 13:18:07 seb Exp $
--- lib/Makefile.in.orig Mon Feb 3 18:50:31 2003
+++ lib/Makefile.in
@@ -1,6 +1,6 @@
-# Makefile.in generated automatically by automake 1.4 from Makefile.am
+# Makefile.in generated automatically by automake 1.4-p6 from Makefile.am
-# Copyright (C) 1994, 1995-8, 1999 Free Software Foundation, Inc.
+# Copyright (C) 1994, 1995-8, 1999, 2001 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -137,6 +137,7 @@ JAVAROOT = @JAVAROOT@
JAVA_INCLUDES = @JAVA_INCLUDES@
KRB_INC_FLAGS = @KRB_INC_FLAGS@
KRB_LIB_FLAGS = @KRB_LIB_FLAGS@
+LIBOBJS = @LIBOBJS@
LIBSSL_INC_DIR = @LIBSSL_INC_DIR@
LIBSSL_INC_FLAGS = @LIBSSL_INC_FLAGS@
LIBSSL_LIB_DIR = @LIBSSL_LIB_DIR@
@@ -152,6 +153,7 @@ LIB_SOCKET = @LIB_SOCKET@
LN_S = @LN_S@
LTGETADDRINFOOBJS = @LTGETADDRINFOOBJS@
LTGETNAMEINFOOBJS = @LTGETNAMEINFOOBJS@
+LTLIBOBJS = @LTLIBOBJS@
LTSNPRINTFOBJS = @LTSNPRINTFOBJS@
MAKEINFO = @MAKEINFO@
NM = @NM@
@@ -197,10 +199,7 @@ noinst_LIBRARIES = @SASL_STATIC_LIBS@
libsasl2_a_SOURCES =
common_headers = saslint.h
-common_sources = auxprop.c canonusr.c checkpw.c client.c common.c config.c external.c md5.c saslutil.c server.c seterror.c dlopen.c
-
-LTLIBOBJS = @LTLIBOBJS@ plugin_common.lo
-LIBOBJS = @LIBOBJS@ plugin_common.o
+common_sources = auxprop.c canonusr.c checkpw.c client.c common.c config.c external.c md5.c saslutil.c server.c seterror.c dlopen.c plugin_common.c
lib_LTLIBRARIES = libsasl2.la
@@ -227,7 +226,7 @@ LTLIBRARIES = $(lib_LTLIBRARIES)
libsasl2_la_OBJECTS = auxprop.lo canonusr.lo checkpw.lo client.lo \
common.lo config.lo external.lo md5.lo saslutil.lo server.lo \
-seterror.lo dlopen.lo
+seterror.lo dlopen.lo plugin_common.lo
CFLAGS = @CFLAGS@
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
@@ -239,7 +238,7 @@ getsubopt.c snprintf.c
DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
-TAR = gtar
+TAR = tar
GZIP_ENV = --best
SOURCES = $(libsasl2_a_SOURCES) $(libsasl2_la_SOURCES)
OBJECTS = $(libsasl2_a_OBJECTS) $(libsasl2_la_OBJECTS)
@@ -456,13 +455,9 @@ distclean-generic clean-generic maintain
mostlyclean distclean maintainer-clean
-plugin_common.lo: plugin_common.o
- rm -f plugin_common.lo
- ln -s $(top_builddir)/plugins/plugin_common.lo plugin_common.lo
-
-plugin_common.o:
- rm -f plugin_common.o
- ln -s $(top_builddir)/plugins/plugin_common.o plugin_common.o
+plugin_common.c:
+ rm -f plugin_common.c
+ ln -s $(top_builddir)/plugins/plugin_common.c plugin_common.c
@MACOSX_TRUE@install-exec-hook:
@MACOSX_TRUE@ $(mkinstalldirs) $(framedir)/Versions/A
@MACOSX_TRUE@ ln -fs $(libdir)/libsasl2.dylib $(framedir)/Versions/A/SASL2