pkgsrc/www/firefox/patches/patch-probes_Makefile.in
ryoon b629d6fdf5 Update to 31.0
Changelog:
    New
    Add the search field to the new tab page

    New
    Support of Prefer:Safe http header for parental control (learn more)

    New
    mozilla::pkix as default certificate verifier (learn more)

    New
    Block malware from downloaded files (learn more)

    New
    Partial implementation of the OpenType MATH table (section 6.3.6) see documentation about mathematical fonts and the MathML Torture Test for details

    New
    audio/video .ogg and .pdf files handled by Firefox if no application specified (Windows only)

    New
    Upper Sorbian [hsb] locale added

    Changed
    Removal of the CAPS infrastructure for specifying site-specific permissions (via capability.policy.* preferences). Most notably, attempts to use this functionality to grant access to the clipboard will no longer work. The sole exception is the checkloaduri permission, which may still be used as before to allow sites to load file:// URIs.

    HTML5
    WebVTT implemented and enabled (learn more)

    HTML5
    CSS3 variables implemented (learn more)

    Developer
    Developer Tools: Add-on Debugger (learn more)

    Developer
    Developer Tools: Canvas Debugger (learn more)

    Developer
    New Array built-in: Array.prototype.fill() (learn more)

    Developer
    New Object built-in: Object.setPrototypeOf() (learn more)

    Developer
    CSP 1.1 nonce-source and hash-source enabled by default

    Developer
    Developer Tools: Eyedropper tool added to the color picker (learn more)

    Developer
    Developer Tools: Editable Box Model (learn more)

    Developer
    Developer Tools: Code Editor improvements (learn more)

    Developer
    Developer Tools: Console stack traces (learn more)

    Developer
    Developer Tools: Copy as cURL (learn more)

    Developer
    Developer Tools: Styled console logs (learn more)

    Developer
    navigator.sendBeacon enabled by default (learn more)

    Developer
    Dialogs spawned from the onbeforeunload event no longer block access to the rest of the browser

    Fixed
    Search for partially selected link text from context menu (985824)

    Fixed
    Various security fixes

Fixed in Firefox 31
MFSA 2014-66 IFRAME sandbox same-origin access through redirect
MFSA 2014-65 Certificate parsing broken by non-standard character encoding
MFSA 2014-64 Crash in Skia library when scaling high quality images
MFSA 2014-63 Use-after-free while when manipulating certificates in the trusted cache
MFSA 2014-62 Exploitable WebGL crash with Cesium JavaScript library
MFSA 2014-61 Use-after-free with FireOnStateChange event
MFSA 2014-60 Toolbar dialog customization event spoofing
MFSA 2014-59 Use-after-free in DirectWrite font handling
MFSA 2014-58 Use-after-free in Web Audio due to incorrect control message ordering
MFSA 2014-57 Buffer overflow during Web Audio buffering for playback
MFSA 2014-56 Miscellaneous memory safety hazards (rv:31.0 / rv:24.7)
2014-07-24 14:57:12 +00:00

13 lines
620 B
Text

$NetBSD: patch-probes_Makefile.in,v 1.1 2014/07/24 14:57:12 ryoon Exp $
--- probes/Makefile.in.orig 2014-07-17 01:45:36.000000000 +0000
+++ probes/Makefile.in
@@ -7,7 +7,7 @@ export:: $(DIST)/include/mozilla-trace.h
# Replace _DTRACE_VERSION with INCLUDE_MOZILLA_DTRACE
$(DIST)/include/mozilla-trace.h: mozilla-trace.d Makefile
- dtrace -h -s $(srcdir)/mozilla-trace.d -o mozilla-trace.h.tmp
+ dtrace -x nolibs -h -s $(srcdir)/mozilla-trace.d -o mozilla-trace.h.tmp
sed -e 's/if _DTRACE_VERSION/ifdef INCLUDE_MOZILLA_DTRACE/' \
mozilla-trace.h.tmp > $(DIST)/include/mozilla-trace.h
rm mozilla-trace.h.tmp