f27ca028c5
Patched version of 3.6.0 to fix potentially serious bug described at http://www.unidata.ucar.edu/packages/netcdf/docs/known_problems.html#cdf2-bug Changes 3.6.0: Added texinfo source for the documentation. Added large file tests to Windows directory in distribution. Modified win32 visual studio project files so that m4 is no longer required to build netcdf under visual studio. Modified rules.make to use install instead of cp, fixing install problem for cygwin users. Modified configure/install stuff to support HP-UX. Modified configure/install stuff to support G95. In the f90 interface, applied Arnaud Desitter's fixes to correct mismatches between scalar and array arguments, eliminating (legitimate) complaints by the NAGWare f95 compiler. Also fixed bugs introduced in 3.6.0-beta5 in the mapped array interfaces.
38 lines
952 B
Text
38 lines
952 B
Text
$NetBSD: patch-af,v 1.2 2005/02/25 09:52:47 adam Exp $
|
|
|
|
--- libsrc/Makefile.orig 2004-12-18 18:08:01.000000000 +0000
|
|
+++ libsrc/Makefile
|
|
@@ -7,7 +7,7 @@ include ../macros.make
|
|
|
|
INCLUDES = -I.
|
|
|
|
-LIBRARY = libnetcdf.a
|
|
+LIBRARY = libnetcdf.la
|
|
ld_netcdf = -L. -lnetcdf
|
|
|
|
HEADER = netcdf.h
|
|
@@ -54,7 +54,23 @@ PACKING_LIST = \
|
|
t_ncxx.c \
|
|
t_ncx.c install-sh
|
|
|
|
-LIB_OBJS = $(LIB_CSRCS:.c=.o)
|
|
+FLIB_OBJS = \
|
|
+ ../fortran/fort-attio.o \
|
|
+ ../fortran/fort-control.o \
|
|
+ ../fortran/fort-dim.o \
|
|
+ ../fortran/fort-genatt.o \
|
|
+ ../fortran/fort-geninq.o \
|
|
+ ../fortran/fort-genvar.o \
|
|
+ ../fortran/fort-lib.o \
|
|
+ ../fortran/fort-misc.o \
|
|
+ ../fortran/fort-v2compat.o \
|
|
+ ../fortran/fort-vario.o \
|
|
+ ../fortran/fort-var1io.o \
|
|
+ ../fortran/fort-varaio.o \
|
|
+ ../fortran/fort-varmio.o \
|
|
+ ../fortran/fort-varsio.o
|
|
+
|
|
+LIB_OBJS = $(LIB_CSRCS:.c=.o) $(FLIB_OBJS)
|
|
|
|
GARBAGE = t_ncio.o t_ncio t_ncx.o t_ncx t_ncxx.o t_ncxx \
|
|
t_nc.o t_nc test.nc *.so
|