pkgsrc/audio/mp3blaster/patches/patch-ab
cube b6c92f8952 Update to version 3.2.0.
V3.2.0 2003/11/28
=================
-Updated source to compile with recent gcc compilers
-Pausing mp3/wav/ogg playback releases the sound device
-Better mp3 integrity checks. Songs that didn't previously play (or only
 partly), should now play fine (as in, the bits that are valid)
-Fixed a bug that would hang mp3blaster if you'd be in a dir that was deleted
 meanwhile.
-bugfix that could crash mp3blaster after a request to quit (..)
-bugfix that failed to redraw screen correctly after operations that
 required input (such as convert to wav, enter group name, ..)
-fixed a bug that could crash mp3blaster on opening oggs when sound device
 was busy.
-Check if the playlist directory actually exists before trying to write
 a playlist
-Added '--repeat/-R' command line option
-Applied LIRC support patch from Olgierd Pieczul .
 Thanks a lot!
2003-12-03 12:31:36 +00:00

264 lines
10 KiB
Text

$NetBSD: patch-ab,v 1.5 2003/12/03 12:31:36 cube Exp $
--- src/Makefile.in.orig 2003-11-28 21:07:27.000000000 +0100
+++ src/Makefile.in
@@ -10,6 +10,8 @@
# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
# PARTICULAR PURPOSE.
+#bin_PROGRAMS = mp3blaster mp3tag splay
+
SHELL = @SHELL@
@@ -63,6 +65,7 @@ CC = @CC@
CXX = @CXX@
HAVE_LIB = @HAVE_LIB@
LIB = @LIB@
+LIBGETOPT = @LIBGETOPT@
LIBMPEGSOUND = @LIBMPEGSOUND@
LIBMYSQL = @LIBMYSQL@
LIBNMIXER = @LIBNMIXER@
@@ -81,19 +84,15 @@ SID_LIBS = @SID_LIBS@
SRCDIRS = @SRCDIRS@
VERSION = @VERSION@
-bin_PROGRAMS = mp3blaster mp3tag splay
-#bin_PROGRAMS = mp3blaster mp3tag
-mp3blaster_SOURCES = fileman.cc main.cc scrollwin.cc getopt.c getopt1.c fileman.h genretab.h getopt.h id3parse.cc id3parse.h mp3blaster.h global.cc global.h config.cc scrollwin.h winitem.cc winitem.h mp3win.cc mp3win.h mp3item.cc mp3item.h keybindings.h history.cc history.h getinput.cc getinput.h interface.cc interface.h
-
-splay_SOURCES = splay.cc splay.h splay_common.cc
-splay_DEPENDENCIES = ../mpegsound/libmpegsound.a
-splay_LDADD = @LIBMPEGSOUND@
+bin_PROGRAMS = mp3blaster mp3tag
+mp3blaster_SOURCES = fileman.cc main.cc scrollwin.cc fileman.h genretab.h id3parse.cc id3parse.h mp3blaster.h global.cc global.h config.cc scrollwin.h winitem.cc winitem.h mp3win.cc mp3win.h mp3item.cc mp3item.h keybindings.h history.cc history.h getinput.cc getinput.h interface.cc interface.h
+
mp3tag_SOURCES = id3parse.cc mp3tag.cc id3parse.h
mp3tag_DEPENDENCIES = ../mpegsound/libmpegsound.a ../nmixer/libnmixer.a
mp3tag_LDADD = @LIBMPEGSOUND@ @LIBMYSQL@
-mp3blaster_DEPENDENCIES = ../mpegsound/libmpegsound.a ../nmixer/libnmixer.a
+mp3blaster_DEPENDENCIES = ../mpegsound/libmpegsound.a ../nmixer/libnmixer.a ../getopt/libgetopt.a
INCLUDES = -I$(top_srcdir)/mpegsound -I/usr/include/ncurses -I$(top_srcdir)/nmixer -I$(includedir)
-mp3blaster_LDADD = @LIBMPEGSOUND@ @LIBNMIXER@ @NAS_LIBS@ @SID_LIBS@ @OGG_LIBS@ @LIRC_LIBS@ @NCURSES_LIBS@
+mp3blaster_LDADD = @LIBMPEGSOUND@ @LIBNMIXER@ @LIBGETOPT@ @NAS_LIBS@ @SID_LIBS@ @OGG_LIBS@ @LIRC_LIBS@ @NCURSES_LIBS@
EXTRA_DIST = FILES
CXXFLAGS = @CXXFLAGS@ @NAS_CFLAGS@ -DMP3BLASTER_DOCDIR=\"${pkgdatadir}\"
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
@@ -110,14 +109,11 @@ X_CFLAGS = @X_CFLAGS@
X_LIBS = @X_LIBS@
X_EXTRA_LIBS = @X_EXTRA_LIBS@
X_PRE_LIBS = @X_PRE_LIBS@
-mp3blaster_OBJECTS = fileman.o main.o scrollwin.o getopt.o getopt1.o \
-id3parse.o global.o config.o winitem.o mp3win.o mp3item.o history.o \
-getinput.o interface.o
+mp3blaster_OBJECTS = fileman.o main.o scrollwin.o id3parse.o global.o \
+config.o winitem.o mp3win.o mp3item.o history.o getinput.o interface.o
mp3blaster_LDFLAGS =
mp3tag_OBJECTS = id3parse.o mp3tag.o
mp3tag_LDFLAGS =
-splay_OBJECTS = splay.o splay_common.o
-splay_LDFLAGS =
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
CXXLD = $(CXX)
CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
@@ -132,16 +128,20 @@ DISTFILES = $(DIST_COMMON) $(SOURCES) $(
TAR = tar
GZIP_ENV = --best
-SOURCES = $(mp3blaster_SOURCES) $(mp3tag_SOURCES) $(splay_SOURCES)
-OBJECTS = $(mp3blaster_OBJECTS) $(mp3tag_OBJECTS) $(splay_OBJECTS)
+DEP_FILES = .deps/config.P .deps/fileman.P .deps/getinput.P \
+.deps/global.P .deps/history.P .deps/id3parse.P .deps/interface.P \
+.deps/main.P .deps/mp3item.P .deps/mp3tag.P .deps/mp3win.P \
+.deps/scrollwin.P .deps/winitem.P
+SOURCES = $(mp3blaster_SOURCES) $(mp3tag_SOURCES)
+OBJECTS = $(mp3blaster_OBJECTS) $(mp3tag_OBJECTS)
all: all-redirect
.SUFFIXES:
.SUFFIXES: .S .c .cc .o .s
$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
- cd $(top_srcdir) && $(AUTOMAKE) --gnu --include-deps src/Makefile
+ cd $(top_srcdir) && $(AUTOMAKE) --gnu src/Makefile
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status $(BUILT_SOURCES)
cd $(top_builddir) \
&& CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
@@ -171,9 +171,6 @@ uninstall-binPROGRAMS:
rm -f $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
done
-.c.o:
- $(COMPILE) -c $<
-
.s.o:
$(COMPILE) -c $<
@@ -197,10 +194,6 @@ mp3blaster: $(mp3blaster_OBJECTS) $(mp3b
mp3tag: $(mp3tag_OBJECTS) $(mp3tag_DEPENDENCIES)
@rm -f mp3tag
$(CXXLINK) $(mp3tag_LDFLAGS) $(mp3tag_OBJECTS) $(mp3tag_LDADD) $(LIBS)
-
-splay: $(splay_OBJECTS) $(splay_DEPENDENCIES)
- @rm -f splay
- $(CXXLINK) $(splay_LDFLAGS) $(splay_OBJECTS) $(splay_LDADD) $(LIBS)
.cc.o:
$(CXXCOMPILE) -c $<
@@ -222,7 +215,7 @@ TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEP
awk ' { files[$$0] = 1; } \
END { for (i in files) print i; }'`; \
test -z "$(ETAGS_ARGS)$$unique$(LISP)$$tags" \
- || (cd $(srcdir) && etags -o $$here/TAGS $(ETAGS_ARGS) $$tags $$unique $(LISP))
+ || (cd $(srcdir) && etags $(ETAGS_ARGS) $$tags $$unique $(LISP) -o $$here/TAGS)
mostlyclean-tags:
@@ -238,6 +231,11 @@ distdir = $(top_builddir)/$(PACKAGE)-$(V
subdir = src
distdir: $(DISTFILES)
+ here=`cd $(top_builddir) && pwd`; \
+ top_distdir=`cd $(top_distdir) && pwd`; \
+ distdir=`cd $(distdir) && pwd`; \
+ cd $(top_srcdir) \
+ && $(AUTOMAKE) --include-deps --build-dir=$$here --srcdir-name=$(top_srcdir) --output-dir=$$top_distdir --gnu src/Makefile
@for file in $(DISTFILES); do \
d=$(srcdir); \
if test -d $$d/$$file; then \
@@ -248,33 +246,57 @@ distdir: $(DISTFILES)
|| cp -p $$d/$$file $(distdir)/$$file || :; \
fi; \
done
-config.o: config.cc mp3blaster.h ../config.h global.h
-fileman.o: fileman.cc mp3blaster.h ../config.h getopt.h fileman.h \
- scrollwin.h winitem.h global.h
-getinput.o: getinput.cc getinput.h ../config.h
-getopt.o: getopt.c ../config.h
-getopt1.o: getopt1.c ../config.h getopt.h
-global.o: global.cc getopt.h mp3blaster.h ../config.h id3parse.h
-history.o: history.cc ../config.h history.h getopt.h
-id3parse.o: id3parse.cc id3parse.h genretab.h
-interface.o: interface.cc
-main.o: main.cc ../config.h history.h getopt.h mp3blaster.h global.h \
- scrollwin.h winitem.h mp3win.h fileman.h \
- ../mpegsound/mpegsound.h ../nmixer/nmixer.h keybindings.h \
- getinput.h
-mp3item.o: mp3item.cc mp3item.h winitem.h mp3blaster.h ../config.h \
- mp3win.h scrollwin.h
-mp3tag.o: mp3tag.cc mp3blaster.h ../config.h getopt.h \
- ../mpegsound/mpegsound.h id3parse.h
-mp3win.o: mp3win.cc mp3win.h scrollwin.h mp3blaster.h ../config.h \
- winitem.h mp3item.h
-scrollwin.o: scrollwin.cc mp3blaster.h ../config.h global.h scrollwin.h \
- winitem.h
-splay.o: splay.cc ../config.h getopt.h ../mpegsound/mpegsound.h splay.h
-splay_common.o: splay_common.cc ../config.h ../mpegsound/mpegsound.h \
- getopt.h splay.h
-winitem.o: winitem.cc mp3blaster.h ../config.h scrollwin.h winitem.h
+DEPS_MAGIC := $(shell mkdir .deps > /dev/null 2>&1 || :)
+
+-include $(DEP_FILES)
+
+mostlyclean-depend:
+
+clean-depend:
+
+distclean-depend:
+ -rm -rf .deps
+
+maintainer-clean-depend:
+
+%.o: %.c
+ @echo '$(COMPILE) -c $<'; \
+ $(COMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
+ @-cp .deps/$(*F).pp .deps/$(*F).P; \
+ tr ' ' '\012' < .deps/$(*F).pp \
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
+ >> .deps/$(*F).P; \
+ rm .deps/$(*F).pp
+
+%.lo: %.c
+ @echo '$(LTCOMPILE) -c $<'; \
+ $(LTCOMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
+ @-sed -e 's/^\([^:]*\)\.o[ ]*:/\1.lo \1.o :/' \
+ < .deps/$(*F).pp > .deps/$(*F).P; \
+ tr ' ' '\012' < .deps/$(*F).pp \
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
+ >> .deps/$(*F).P; \
+ rm -f .deps/$(*F).pp
+
+%.o: %.cc
+ @echo '$(CXXCOMPILE) -c $<'; \
+ $(CXXCOMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
+ @-cp .deps/$(*F).pp .deps/$(*F).P; \
+ tr ' ' '\012' < .deps/$(*F).pp \
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
+ >> .deps/$(*F).P; \
+ rm .deps/$(*F).pp
+
+%.lo: %.cc
+ @echo '$(LTCXXCOMPILE) -c $<'; \
+ $(LTCXXCOMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
+ @-sed -e 's/^\([^:]*\)\.o[ ]*:/\1.lo \1.o :/' \
+ < .deps/$(*F).pp > .deps/$(*F).P; \
+ tr ' ' '\012' < .deps/$(*F).pp \
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
+ >> .deps/$(*F).P; \
+ rm -f .deps/$(*F).pp
info-am:
info: info-am
dvi-am:
@@ -312,23 +334,24 @@ distclean-generic:
maintainer-clean-generic:
mostlyclean-am: mostlyclean-binPROGRAMS mostlyclean-compile \
- mostlyclean-tags mostlyclean-generic
+ mostlyclean-tags mostlyclean-depend mostlyclean-generic
mostlyclean: mostlyclean-am
-clean-am: clean-binPROGRAMS clean-compile clean-tags clean-generic \
- mostlyclean-am
+clean-am: clean-binPROGRAMS clean-compile clean-tags clean-depend \
+ clean-generic mostlyclean-am
clean: clean-am
distclean-am: distclean-binPROGRAMS distclean-compile distclean-tags \
- distclean-generic clean-am
+ distclean-depend distclean-generic clean-am
distclean: distclean-am
maintainer-clean-am: maintainer-clean-binPROGRAMS \
maintainer-clean-compile maintainer-clean-tags \
- maintainer-clean-generic distclean-am
+ maintainer-clean-depend maintainer-clean-generic \
+ distclean-am
@echo "This command is intended for maintainers to use;"
@echo "it deletes files that may require special tools to rebuild."
@@ -338,12 +361,13 @@ maintainer-clean: maintainer-clean-am
maintainer-clean-binPROGRAMS uninstall-binPROGRAMS install-binPROGRAMS \
mostlyclean-compile distclean-compile clean-compile \
maintainer-clean-compile tags mostlyclean-tags distclean-tags \
-clean-tags maintainer-clean-tags distdir info-am info dvi-am dvi check \
-check-am installcheck-am installcheck install-exec-am install-exec \
-install-data-am install-data install-am install uninstall-am uninstall \
-all-redirect all-am all installdirs mostlyclean-generic \
-distclean-generic clean-generic maintainer-clean-generic clean \
-mostlyclean distclean maintainer-clean
+clean-tags maintainer-clean-tags distdir mostlyclean-depend \
+distclean-depend clean-depend maintainer-clean-depend info-am info \
+dvi-am dvi check check-am installcheck-am installcheck install-exec-am \
+install-exec install-data-am install-data install-am install \
+uninstall-am uninstall all-redirect all-am all installdirs \
+mostlyclean-generic distclean-generic clean-generic \
+maintainer-clean-generic clean mostlyclean distclean maintainer-clean
@MP3B_MODULES@